CVE-2002-2407
CVSS6.9
发布时间 :2002-12-31 00:00:00
修订时间 :2008-09-05 16:33:08
NMCO    

[原文]Certain patches for QNX Neutrino realtime operating system (RTOS) 6.2.0 set insecure permissions for the files (1) /sbin/io-audio by OS Update Patch A, (2) /bin/shutdown, (3) /sbin/fs-pkg, and (4) phshutdown by QNX experimental patches, (5) cpim, (6) vpim, (7) phrelaycfg, and (8) columns, (9) othello, (10) peg, (11) solitaire, and (12) vpoker in the games pack 2.0.3, which allows local users to gain privileges by modifying the files before permissions are changed.


[CNNVD]QNX多个程序不安全默认权限漏洞(CNNVD-200212-345)

        
        QNX RTOS是一款设计用于嵌入系统的实时操作系统,由QNX分发和维护。
        QNX多个程序默认权限设置不正确,本地攻击者可以利用这个漏洞删除文件,更改文件内容,或者以木马程序代替系统文件导致权限提升。
        QNX在安装OS Update for 6.2.0 (Patch A)补丁后会影响io-audio权限。QNX也发布两个以下两个补丁,可导致错误的程序权限:
         - PhShutdown security patch
         - Package file system patch
        系统中如下程序其权限为全局可读/写:
        /sbin/io-audio
        /bin/shutdown
        /sbin/fs-pkg
        /usr/photon/bin/phshutdown
        /usr/photon/bin/cpim
        /usr/photon/bin/vpim
        /usr/photon/bin/phrelaycfg
        /usr/photon/bin/columns
        /usr/photon/bin/othello
        /usr/photon/bin/peg
        /usr/photon/bin/solitaire
        /usr/photon/bin/vpoker
        

- CVSS (基础分值)

CVSS分值: 6.9 [中等(MEDIUM)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-264 [权限、特权与访问控制]

- CPE (受影响的平台与产品)

cpe:/a:qnx:rtos:6.2a
cpe:/a:qnx:rtos:6.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-2407
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-2407
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200212-345
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/6206
(UNKNOWN)  BID  6206
http://www.iss.net/security_center/static/10656.php
(UNKNOWN)  XF  qnx-rtos-improper-permissions(10656)
http://archives.neohapsis.com/archives/bugtraq/2002-11/0255.html
(UNKNOWN)  BUGTRAQ  20021119 Multiple incorrect permissions in QNX.

- 漏洞信息

QNX多个程序不安全默认权限漏洞
中危 配置错误
2002-12-31 00:00:00 2002-12-31 00:00:00
本地  
        
        QNX RTOS是一款设计用于嵌入系统的实时操作系统,由QNX分发和维护。
        QNX多个程序默认权限设置不正确,本地攻击者可以利用这个漏洞删除文件,更改文件内容,或者以木马程序代替系统文件导致权限提升。
        QNX在安装OS Update for 6.2.0 (Patch A)补丁后会影响io-audio权限。QNX也发布两个以下两个补丁,可导致错误的程序权限:
         - PhShutdown security patch
         - Package file system patch
        系统中如下程序其权限为全局可读/写:
        /sbin/io-audio
        /bin/shutdown
        /sbin/fs-pkg
        /usr/photon/bin/phshutdown
        /usr/photon/bin/cpim
        /usr/photon/bin/vpim
        /usr/photon/bin/phrelaycfg
        /usr/photon/bin/columns
        /usr/photon/bin/othello
        /usr/photon/bin/peg
        /usr/photon/bin/solitaire
        /usr/photon/bin/vpoker
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 手工更改每个程序的全局写权限。
        厂商补丁:
        QNX
        ---
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.qnx.com/

- 漏洞信息

60250
QNX RTOS OS Update Patch A /sbin/io-audio Permission Weakness Local Privilege Escalation
Local Access Required Misconfiguration, Race Condition
Loss of Integrity Workaround
Exploit Public

- 漏洞描述

Unknown or Incomplete

- 时间线

2002-11-19 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站