CVE-2002-2381
CVSS7.5
发布时间 :2002-12-31 00:00:00
修订时间 :2008-09-05 16:33:04
NMCO    

[原文]Multiple buffer overflows in (1) tetrinet_inmessage, (2) speclist_add and (3) config-getthemeinfo of GTetrinet 0.4.3 and earlier allow remote attackers to casue a denial of service and possibly execute arbitrary code.


[CNNVD]GTetrinet多个远程缓冲区溢出漏洞(CNNVD-200212-780)

        
        GTetrinet是一款免费开放源代码基于网络的Tetris游戏客户端。
        GTetrinet客户端存在多个缓冲区溢出问题,远程攻击者可以利用这些漏洞伪造游戏服务器应答,对客户端进行拒绝服务攻击,可能以当前用户权限在系统上执行任意指令。
        GTetrinet多处代码没有进行正确的缓冲区边界检查,攻击者可以通过控制游戏服务器,伪造服务器应答,进行缓冲区溢出攻击,精心构建应答数据可能以当前用户权限在系统上执行任意指令。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-119 [内存缓冲区边界内操作的限制不恰当]

- CPE (受影响的平台与产品)

cpe:/a:ka-shu_wong:gtetrinet:0.4.1
cpe:/a:ka-shu_wong:gtetrinet:0.4.2
cpe:/a:ka-shu_wong:gtetrinet:0.4.3
cpe:/a:ka-shu_wong:gtetrinet:0.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-2381
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-2381
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200212-780
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/6062
(PATCH)  BID  6062
http://securitytracker.com/id?1005497
(PATCH)  SECTRACK  1005497
http://www.iss.net/security_center/static/10511.php
(UNKNOWN)  XF  gtetrinet-multiple-functions-bo(10511)
http://www.derkeiler.com/Mailing-Lists/securityfocus/bugtraq/2002-11/0303.html
(UNKNOWN)  GENTOO  200211-006
http://www.debian.org/security/2002/dsa-205
(UNKNOWN)  DEBIAN  DSA-205

- 漏洞信息

GTetrinet多个远程缓冲区溢出漏洞
高危 边界条件错误
2002-12-31 00:00:00 2002-12-31 00:00:00
远程  
        
        GTetrinet是一款免费开放源代码基于网络的Tetris游戏客户端。
        GTetrinet客户端存在多个缓冲区溢出问题,远程攻击者可以利用这些漏洞伪造游戏服务器应答,对客户端进行拒绝服务攻击,可能以当前用户权限在系统上执行任意指令。
        GTetrinet多处代码没有进行正确的缓冲区边界检查,攻击者可以通过控制游戏服务器,伪造服务器应答,进行缓冲区溢出攻击,精心构建应答数据可能以当前用户权限在系统上执行任意指令。
        

- 公告与补丁

        厂商补丁:
        GTetrinet
        ---------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        GTetrinet Upgrade gtetrinet-0.4.4.tar.gz
        
        http://download.sourceforge.net/gtetrinet/gtetrinet-0.4.4.tar.gz

- 漏洞信息

60260
GTetrinet Multiple Functions Remote Overflow
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2002-10-29 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.4.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站