CVE-2002-2347
CVSS4.3
发布时间 :2002-12-31 00:00:00
修订时间 :2008-09-05 16:32:59
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in Oracle Java Server Page (OJSP) demo files (1) hellouser.jsp, (2) welcomeuser.jsp and (3) usebean.jsp in Oracle 9i Application Server 9.0.2, 1.0.2.2, 1.0.2.1s and 1.0.2 allows remote attackers to inject arbitrary web script or HTML via the text entry field.


[CNNVD]Oracle 9iAS OJSP Demo脚本跨站脚本攻击(XSS)漏洞(CNNVD-200212-409)

        Oracle 9i Application Server 9.0.2,1.0.2.2,1.0.2.1s和1.0.2O版本的Oracle Java Server Page (OJSP) demo文件(1)hellouser.jsp,(2)welcomeuser.jsp,和(3)usebean.jsp存在跨站脚本攻击(XSS)漏洞。远程攻击者可以借助text entry字段注入任意web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-79 [在Web页面生成时对输入的转义处理不恰当(跨站脚本)]

- CPE (受影响的平台与产品)

cpe:/a:oracle:application_server:1.0.2.2Oracle Application Server 9i 1.0.2.2
cpe:/a:oracle:application_server:9.0.2Oracle Application Server 9i 9.0.2
cpe:/a:oracle:application_server:1.0.2Oracle Application Server 9i 1.0.2
cpe:/a:oracle:application_server:1.0.2.1sOracle Application Server 9i 1.0.2.1s

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-2347
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-2347
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200212-409
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/5452
(UNKNOWN)  BID  5452
http://www.iss.net/security_center/static/9842.php
(UNKNOWN)  XF  oracle-appserver-ojsp-xss(9842)
http://otn.oracle.com/deploy/security/pdf/2002alert41rev1.pdf
(UNKNOWN)  CONFIRM  http://otn.oracle.com/deploy/security/pdf/2002alert41rev1.pdf

- 漏洞信息

Oracle 9iAS OJSP Demo脚本跨站脚本攻击(XSS)漏洞
中危 跨站脚本
2002-12-31 00:00:00 2002-12-31 00:00:00
远程  
        Oracle 9i Application Server 9.0.2,1.0.2.2,1.0.2.1s和1.0.2O版本的Oracle Java Server Page (OJSP) demo文件(1)hellouser.jsp,(2)welcomeuser.jsp,和(3)usebean.jsp存在跨站脚本攻击(XSS)漏洞。远程攻击者可以借助text entry字段注入任意web脚本或HTML。

- 公告与补丁

        The vendor advises administrators to remove the OJSP demo scripts. This may be accomplished by remnoving the following JSP files:
        /ora9ias/j2ee/OC4J_Demos/applications/ojspdemos/ojspdemos-web/basic/simple
        /ora9ias/j2ee/OC4J_Demos/applications/ojspdemos/ojspdemos-web/basic/hellouser
        This issue will reportedly be addressed in Oracle 9iAS version 9.0.3, which is expected to be released in the fall of 2002.

- 漏洞信息

44550
Oracle Application Server OJSP /ojspdemos/basic/hellouser/hellouser.jsp XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

- 时间线

2002-08-14 Unknow
Unknow Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站