CVE-2002-2333
CVSS5.0
发布时间 :2002-12-31 00:00:00
修订时间 :2008-09-05 16:32:57
NMCO    

[原文]Buffer overflow in konqueror in KDE 2.1 through 3.0 and 3.0.2 allows remote attackers to cause a denial of service (crash) via an IMG tag with large width and height attributes.


[CNNVD]KDE Konqueror超大图像宽度拒绝服务漏洞(CNNVD-200212-828)

        从KDE 2.1到 3.0 版本和3.0.2版本konqueror存在缓冲区溢出漏洞。远程攻击者借助具有超大宽度和超大高度属性的IMG标签导致服务拒绝(崩溃)。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-119 [内存缓冲区边界内操作的限制不恰当]

- CPE (受影响的平台与产品)

cpe:/o:kde:kde:3.0
cpe:/o:kde:kde:2.2
cpe:/o:kde:kde:3.0.2
cpe:/o:kde:kde:2.1.1
cpe:/o:kde:kde:2.2.1
cpe:/o:kde:kde:2.2.2
cpe:/o:kde:kde:2.1.2
cpe:/o:kde:kde:2.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-2333
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-2333
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200212-828
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/5721
(PATCH)  BID  5721
http://www.iss.net/security_center/static/10126.php
(UNKNOWN)  XF  opera-konqueror-image-dos(10126)
http://www.derkeiler.com/Mailing-Lists/securityfocus/bugtraq/2002-09/0177.html
(UNKNOWN)  BUGTRAQ  20020917 Re: Bug in Opera and Konqueror
http://www.derkeiler.com/Mailing-Lists/securityfocus/bugtraq/2002-09/0167.html
(UNKNOWN)  BUGTRAQ  20020915 Bug in Opera and Konqueror

- 漏洞信息

KDE Konqueror超大图像宽度拒绝服务漏洞
中危 缓冲区溢出
2002-12-31 00:00:00 2002-12-31 00:00:00
远程  
        从KDE 2.1到 3.0 版本和3.0.2版本konqueror存在缓冲区溢出漏洞。远程攻击者借助具有超大宽度和超大高度属性的IMG标签导致服务拒绝(崩溃)。

- 公告与补丁

        Upgrade to the latest KDE:
        KDE KDE 2.1
        
        KDE KDE 2.1.1
        
        KDE KDE 2.2
        
        KDE KDE 2.2.1
        
        KDE KDE 2.2.2
        
        KDE KDE 3.0
        
        KDE KDE 3.0.2
        

- 漏洞信息

60240
KDE Konqueror Crafted IMG Tag Handling Overflow DoS
Remote / Network Access, Context Dependent Denial of Service, Input Manipulation
Loss of Integrity, Loss of Availability Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2002-09-15 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 3.0.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站