CVE-2002-2304
CVSS7.5
发布时间 :2002-12-31 00:00:00
修订时间 :2008-09-05 16:32:52
NMCOE    

[原文]SQL injection vulnerability in admin/auth/checksession.php in MyPHPLinks 2.1.9 and 2.2.0 allows remote attackers to execute arbitrary SQL commands via the idsession parameter.


[CNNVD]MyPHPSoft MyPHPLinks SQL注入管理验证可绕过漏洞(CNNVD-200212-719)

        
        MyPHPLinks是由MyPHPSoft开发维护的开放源代码PHP应用程序,可使用在Unix、Linux、Windows操作系统下。
        MyPHPLinks中的checksession.php脚本对idsession变量缺少正确检查,远程攻击者可以利用这个漏洞绕过验证无需密码访问管理接口。
        checksession.php脚本对用户的权限检查基于idsession变量,由于对由用户提交的idsession变量值缺少充分的过滤,攻击者可以提供类似''=''的变量值给脚本判断,可修改SQL查询而绕过验证,未授权访问管理员接口。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-89 [SQL命令中使用的特殊元素转义处理不恰当(SQL注入)]

- CPE (受影响的平台与产品)

cpe:/a:myphpsoft:myphplinks:2.2.0
cpe:/a:myphpsoft:myphplinks:2.1.9

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-2304
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-2304
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200212-719
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/10864
(UNKNOWN)  XF  myphplinks-index-sql-injection(10864)
http://www.securityfocus.com/bid/6395
(UNKNOWN)  BID  6395
http://archives.neohapsis.com/archives/bugtraq/2002-12/0134.html
(UNKNOWN)  BUGTRAQ  20021214 MyPHPLinks (PHP) : SQL Injection

- 漏洞信息

MyPHPSoft MyPHPLinks SQL注入管理验证可绕过漏洞
高危 设计错误
2002-12-31 00:00:00 2002-12-31 00:00:00
远程  
        
        MyPHPLinks是由MyPHPSoft开发维护的开放源代码PHP应用程序,可使用在Unix、Linux、Windows操作系统下。
        MyPHPLinks中的checksession.php脚本对idsession变量缺少正确检查,远程攻击者可以利用这个漏洞绕过验证无需密码访问管理接口。
        checksession.php脚本对用户的权限检查基于idsession变量,由于对由用户提交的idsession变量值缺少充分的过滤,攻击者可以提供类似''=''的变量值给脚本判断,可修改SQL查询而绕过验证,未授权访问管理员接口。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * Frog Man <leseulfrog@hotmail.com>提供如下第三方补丁方案:
        
        http://www.phpsecure.org/index.php?zone=pPatchA&sAlpha=m

        厂商补丁:
        MyPHPSoft
        ---------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.myphpsoft.net

- 漏洞信息 (22088)

MyPHPSoft MyPHPLinks 2.1.9/2.2 SQL Injection Administration Bypassing (EDBID:22088)
php webapps
2002-12-14 Verified
0 frog
N/A [点击下载]
source: http://www.securityfocus.com/bid/6395/info

MyPHPLinks is a freely available, open source PHP application distributed by MyPHPSoft. It is available for Unix, Linux, and Microsoft Windows operating systems.

It has been reported that a problem with the checking of input by MyPHPLinks exists. A problem in the checking of the idsession variable used by MyPHPLinks to verify Administrator access may allow a remote user to gain access to the host. This problem could allow an attacker to gain administrator access to the MyPHPLinks section of a web site.

http://www.example.com/admin/index.php?idsession='%20OR%20''='		

- 漏洞信息

41009
MyPHPLinks checksession.php idsession Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity Solution Unknown
Exploit Public Uncoordinated Disclosure

- 漏洞描述

MyPHPLinks contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the 'checksession.php' script not properly sanitizing user-supplied input to the 'idsession' parameter. This may allow an attacker to inject or manipulate SQL queries in the back-end database, allowing for the manipulation or disclosure of arbitrary data.

- 时间线

2002-12-14 Unknow
2002-12-14 Unknow

- 解决方案

OSVDB is not aware of a solution for this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站