发布时间 :2002-12-31 00:00:00
修订时间 :2016-10-17 22:28:01

[原文]Buffer overflow in ftpd 5.4 in 3Com NBX 4.0.17 or ftpd 5.4.2 in 3Com NBX 4.1.4 allows remote attackers to cause a denial of service (crash) via a long CEL command.

[CNNVD]3Com SuperStack 3 NBX FTPD远程拒绝服务攻击漏洞(CNNVD-200212-608)

        3Com Superstack 3 NBX IP电话系统使用嵌入式实时操作系统(EROTS),其中包含FTPD守护程序。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-119 [内存缓冲区边界内操作的限制不恰当]

- CPE (受影响的平台与产品)

cpe:/h:3com:webbngss3nbxnts:4.0.173Com 3Com SuperStack 3 NBX 4.0.17
cpe:/h:3com:webbngss3nbxnts:4.1.213Com 3Com SuperStack 3 NBX 4.1.21
cpe:/h:3com:webbngss3nbxnts:4.1.43Com 3Com SuperStack 3 NBX 4.1.4

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20021202 [VU#317417] Denial of Service condition in vxworks ftpd/3com nbx
(UNKNOWN)  BUGTRAQ  20030427 3com NBX IP Phone Call manager Denial of Service - Update
(UNKNOWN)  BID  6297
(UNKNOWN)  XF  3com-nbx-cel-bo(10739)

- 漏洞信息

3Com SuperStack 3 NBX FTPD远程拒绝服务攻击漏洞
高危 边界条件错误
2002-12-31 00:00:00 2002-12-31 00:00:00
        3Com Superstack 3 NBX IP电话系统使用嵌入式实时操作系统(EROTS),其中包含FTPD守护程序。

- 公告与补丁


- 漏洞信息 (22060)

3Com SuperStack 3 NBX 4.0/4.1 FTPD Denial of Service Vulnerability (EDBID:22060)
hardware dos
2002-12-02 Verified
0 Michael S. Scheidell
N/A [点击下载]

It has been reported that the ftpd server, included in the Embedded Real Time Operating System (ERTOS) of 3Com Superstack 3 NBX IP phones, contains a denial of service vulnerability. This issue can be triggered by sending a CEL paramater of excessive length, effectively causing the ftpd server and various VoIP services to no longer respond.

It should be noted that this issue may be similar to the vulnerability described in BID 679.

Although unconfirmed, it should also be noted that due to the nature of this vulnerability under some circumstances it may be exploited to execute arbitrary code.

CEL aaaa[...]aaaa where string is 2048 bytes long		

- 漏洞信息

3Com NBX ftpd CEL Command Remote Overflow
Remote / Network Access Denial of Service, Input Manipulation
Loss of Integrity, Loss of Availability
Exploit Public

- 漏洞描述

A remote overflow exists in ftpd of 3Com NBX 100 and 3Com SuperStack 3 NBX. The 'CEL' command fails to perform proper bounds checking resulting in a buffer overflow. With a specially crafted request containing 2,048 bytes or more, a remote attacker can cause the FTP service to crash and certain management functions to stop working properly resulting in a loss of availability.

- 时间线

2002-12-02 2002-10-31
2002-12-02 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者