CVE-2002-2260
CVSS4.3
发布时间 :2002-12-31 00:00:00
修订时间 :2016-10-17 22:27:55
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in the quips feature in Mozilla Bugzilla 2.10 through 2.17 allows remote attackers to inject arbitrary web script or HTML via the "show all quips" page.


[CNNVD]Bugzilla quips Feature跨站脚本漏洞(CNNVD-200212-615)

        Mozilla Bugzilla 2.10至2.17版本的quips特征存在跨站脚本(XSS)漏洞。远程攻击者可以借助"show all quips"页面注入任意web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-79 [在Web页面生成时对输入的转义处理不恰当(跨站脚本)]

- CPE (受影响的平台与产品)

cpe:/a:mozilla:bugzilla:2.16.7Mozilla Bugzilla 2.16.7
cpe:/a:mozilla:bugzilla:2.17.6Mozilla Bugzilla 2.17.6
cpe:/a:mozilla:bugzilla:2.16.8Mozilla Bugzilla 2.16.8
cpe:/a:mozilla:bugzilla:2.17.7Mozilla Bugzilla 2.17.7
cpe:/a:mozilla:bugzilla:2.14.3Mozilla Bugzilla 2.14.3
cpe:/a:mozilla:bugzilla:2.16.1Mozilla Bugzilla 2.16.1
cpe:/a:mozilla:bugzilla:2.14.4Mozilla Bugzilla 2.14.4
cpe:/a:mozilla:bugzilla:2.16.2Mozilla Bugzilla 2.16.2
cpe:/a:mozilla:bugzilla:2.17.1Mozilla Bugzilla 2.17.1
cpe:/a:mozilla:bugzilla:2.14.5Mozilla Bugzilla 2.14.5
cpe:/a:mozilla:bugzilla:2.16.3Mozilla Bugzilla 2.16.3
cpe:/a:mozilla:bugzilla:2.16.4Mozilla Bugzilla 2.16.4
cpe:/a:mozilla:bugzilla:2.17.3Mozilla Bugzilla 2.17.3
cpe:/a:mozilla:bugzilla:2.16.9Mozilla Bugzilla 2.16.9
cpe:/a:mozilla:bugzilla:2.16:rc1Mozilla Bugzilla 2.16 rc1
cpe:/a:mozilla:bugzilla:2.16.5Mozilla Bugzilla 2.16.5
cpe:/a:mozilla:bugzilla:2.17.4Mozilla Bugzilla 2.17.4
cpe:/a:mozilla:bugzilla:2.16.6Mozilla Bugzilla 2.16.6
cpe:/a:mozilla:bugzilla:2.17.5Mozilla Bugzilla 2.17.5
cpe:/a:mozilla:bugzilla:2.16.10Mozilla Bugzilla 2.16.10
cpe:/a:mozilla:bugzilla:2.16.11Mozilla Bugzilla 2.16.11
cpe:/a:mozilla:bugzilla:2.17Mozilla Bugzilla 2.17
cpe:/a:mozilla:bugzilla:2.16Mozilla Bugzilla 2.16
cpe:/a:mozilla:bugzilla:2.10Mozilla Bugzilla 2.10
cpe:/a:mozilla:bugzilla:2.12Mozilla Bugzilla 2.12
cpe:/a:mozilla:bugzilla:2.14.1Mozilla Bugzilla 2.14.1
cpe:/a:mozilla:bugzilla:2.14.2Mozilla Bugzilla 2.14.2
cpe:/a:mozilla:bugzilla:2.14Mozilla Bugzilla 2.14

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-2260
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-2260
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200212-615
(官方数据源) CNNVD

- 其它链接及资源

http://bugzilla.mozilla.org/show_bug.cgi?id=179329
(PATCH)  CONFIRM  http://bugzilla.mozilla.org/show_bug.cgi?id=179329
http://marc.info/?l=bugtraq&m=103837886416560&w=2
(UNKNOWN)  BUGTRAQ  20021126 XSS vulnerability in Bugzilla if upgraded from 2.10 or earlier
http://www.debian.org/security/2002/dsa-218
(UNKNOWN)  DEBIAN  DSA-218
http://www.securityfocus.com/bid/6257
(PATCH)  BID  6257
http://xforce.iss.net/xforce/xfdb/10707
(PATCH)  XF  bugzilla-quips-xss(10707)

- 漏洞信息

Bugzilla quips Feature跨站脚本漏洞
中危 跨站脚本
2002-12-31 00:00:00 2002-12-31 00:00:00
远程  
        Mozilla Bugzilla 2.10至2.17版本的quips特征存在跨站脚本(XSS)漏洞。远程攻击者可以借助"show all quips"页面注入任意web脚本或HTML。

- 公告与补丁

        Debian has released fixes which address this issue. It should be noted that this issue only affects those Debian users who have upgraded from version 2.10, which isn't provided through Debian. Fixes are provided for Debian users who may have installed Bugzilla 2.10.
        Patches are available for Bugzilla 2.14.4 and 2.16.1. Bugzilla 2.17 users are advised to obtain a patch via CVS. Detailed information is available in the referenced message.
        Fixes are available:
        Mozilla Bugzilla 2.10
        
        Mozilla Bugzilla 2.14
        
        Mozilla Bugzilla 2.14.1
        
        Mozilla Bugzilla 2.14.2
        
        Mozilla Bugzilla 2.14.3
        
        Mozilla Bugzilla 2.14.4
        
        Mozilla Bugzilla 2.16
        
        Mozilla Bugzilla 2.16.1
        
        Mozilla Bugzilla 2.17
        

- 漏洞信息

6401
Bugzilla quips.cgi COMMENTS Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Bugzilla contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate COMMENT variables upon submission to the quips.cgi script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2002-11-09 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.17.1 or higher, as it has been reported to fix this vulnerability. It is also possible to correct the flaw by implementing the following workaround(s): Apply vendor patch for version 2.14.4 and 2.16.1 For 2.17, perform a CVS update. For Bugzilla 2.14.x and 2.16.x users, the quips are stored in the 'data/comments' file. Bugzilla 2.17.x stores quips in a 'quips' table in the database. Stored quips should be checked for escaped html tags.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站