CVE-2002-2223
CVSS5.1
发布时间 :2002-12-31 00:00:00
修订时间 :2008-09-05 16:32:39
NMCO    

[原文]Buffer overflow in NetScreen-Remote 8.0 allows remote attackers to cause a denial of service and possibly execute arbitrary code via crafted Internet Key Exchange (IKE) response packets, possibly including (1) a large Security Parameter Index (SPI) field, (2) large number of payloads, or (3) a long payload.


[CNNVD]Netscreen-Remote VPN客户端IKE包过载远程缓冲区溢出漏洞(CNNVD-200212-370)

        
        Netscreen-Remote VPN客户端可以使用Internet密钥交换协议(IKE)机制进行交换密钥验证。
        Netscreen-Remote VPN客户端在处理带有超大负载的IKE包时缺少正确缓冲区边界检查,远程攻击者可以利用这个漏洞对VPN客户端进行缓冲区溢出攻击。
        这个漏洞存在于所有Netscreen-Remote VPN客户端如果运行在积极模式(Aggressive mode),并且在IKE KEY交换第一阶段中发生。攻击者可以发送带有超多个负载或者超大负载的非法IKE应答包给Netscreen-Remote VPN客户端,可导致缓冲区溢出,使VPN客户端消耗大量系统CPU资源。
        默认情况下,NetScreen-Remote只接收来自信任VPN网关(Main mode)的IKE应答包,但是在积极模式中,非法IKE应答包可以在NetScreen-Remote对VPN网关进行验证前发送,所以攻击者可以以VPN网关的身份对Netscreen-Remote VPN客户端IKE请求进行应答而触发缓冲区溢出,导致拒绝服务攻击。
        <*链接:http://www.netscreen.com/support/alerts/9_6_02.htm
        *>

- CVSS (基础分值)

CVSS分值: 5.1 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:juniper:netscreen_remote_vpn_client:8.0Juniper Remote VPN Client 8.0
cpe:/a:juniper:netscreen_remote_security_client:8.0Juniper Remote Security Client 8.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-2223
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-2223
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200212-370
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/287771
(UNKNOWN)  CERT-VN  VU#287771
http://xforce.iss.net/xforce/xfdb/9850
(UNKNOWN)  XF  ike-response-bo(9850)
http://www.securityfocus.com/bid/5668
(UNKNOWN)  BID  5668
http://www.netscreen.com/support/alerts/9_6_02.htm
(UNKNOWN)  MISC  http://www.netscreen.com/support/alerts/9_6_02.htm

- 漏洞信息

Netscreen-Remote VPN客户端IKE包过载远程缓冲区溢出漏洞
中危 边界条件错误
2002-12-31 00:00:00 2007-02-28 00:00:00
远程  
        
        Netscreen-Remote VPN客户端可以使用Internet密钥交换协议(IKE)机制进行交换密钥验证。
        Netscreen-Remote VPN客户端在处理带有超大负载的IKE包时缺少正确缓冲区边界检查,远程攻击者可以利用这个漏洞对VPN客户端进行缓冲区溢出攻击。
        这个漏洞存在于所有Netscreen-Remote VPN客户端如果运行在积极模式(Aggressive mode),并且在IKE KEY交换第一阶段中发生。攻击者可以发送带有超多个负载或者超大负载的非法IKE应答包给Netscreen-Remote VPN客户端,可导致缓冲区溢出,使VPN客户端消耗大量系统CPU资源。
        默认情况下,NetScreen-Remote只接收来自信任VPN网关(Main mode)的IKE应答包,但是在积极模式中,非法IKE应答包可以在NetScreen-Remote对VPN网关进行验证前发送,所以攻击者可以以VPN网关的身份对Netscreen-Remote VPN客户端IKE请求进行应答而触发缓冲区溢出,导致拒绝服务攻击。
        <*链接:http://www.netscreen.com/support/alerts/9_6_02.htm
        *>

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 设置NetScreen-Remote只接收来自信任VPN网关(Main mode)的IKE应答包。
        厂商补丁:
        NetScreen
        ---------
        Netscreen声称Netscreen-Remote VPN Client 8.1和Netscreen-Remote Security Client会在2002-09-30推出,届时可以通过如下地址下载:
        
        http://www.netscreen.com/support/updates.html
(需要登陆).

- 漏洞信息

60125
NetScreen-Remote IKE Response Packet Handling Remote Overflow
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2002-09-06 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站