发布时间 :2002-12-31 00:00:00
修订时间 :2008-09-05 16:32:32

[原文]The setitimer(2) system call in OpenBSD 2.0 through 3.1 does not properly check certain arguments, which allows local users to write to kernel memory and possibly gain root privileges, possibly via an integer signedness error.

[CNNVD]OpenBSD setitimer(2)内核内存溢出漏洞(CNNVD-200212-776)


- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/o:openbsd:openbsd:2.4OpenBSD 2.4
cpe:/o:openbsd:openbsd:2.3OpenBSD 2.3
cpe:/o:openbsd:openbsd:2.0OpenBSD 2.0
cpe:/o:openbsd:openbsd:2.1OpenBSD 2.1
cpe:/o:openbsd:openbsd:3.1OpenBSD 3.1
cpe:/o:openbsd:openbsd:2.8OpenBSD 2.8
cpe:/o:openbsd:openbsd:2.5OpenBSD 2.5
cpe:/o:openbsd:openbsd:2.9OpenBSD 2.9
cpe:/o:openbsd:openbsd:3.0OpenBSD 3.0
cpe:/o:openbsd:openbsd:2.6OpenBSD 2.6
cpe:/o:openbsd:openbsd:2.2OpenBSD 2.2
cpe:/o:openbsd:openbsd:2.7OpenBSD 2.7

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(VENDOR_ADVISORY)  OPENBSD  20021002 Incorrect argument checking in the setitimer(2) system call may allow an attacker to write to kernel memory.
(VENDOR_ADVISORY)  XF  openbsd-setitimer-memory-overwrite(10278)

- 漏洞信息

OpenBSD setitimer(2)内核内存溢出漏洞
中危 输入验证
2002-12-31 00:00:00 2006-03-03 00:00:00

- 公告与补丁

        OpenBSD为OpenBSD 3.1提供了源码补丁:
        OpenBSD Patch 015_kerntime.patch
        #cd /usr/src
        #patch -p0 < 015_kerntime.patch

- 漏洞信息

OpenBSD setitimer(2) System Call Local Privilege Escalation
Local Access Required Input Manipulation
Loss of Integrity Patch / RCS
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2002-10-02 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

OpenBSD setitimer(2) Kernel Memory Overwrite Vulnerability
Input Validation Error 5861
No Yes
2002-10-02 12:00:00 2007-11-03 01:16:00
Reported by OpenBSD.

- 受影响的程序版本

OpenBSD OpenBSD 2.9
OpenBSD OpenBSD 2.8
OpenBSD OpenBSD 2.7
OpenBSD OpenBSD 2.6
OpenBSD OpenBSD 2.5
OpenBSD OpenBSD 2.4
OpenBSD OpenBSD 2.3
OpenBSD OpenBSD 2.2
OpenBSD OpenBSD 2.1
OpenBSD OpenBSD 2.0
OpenBSD OpenBSD 3.1
OpenBSD OpenBSD 3.0

- 漏洞讨论

OpenBSD has reported a vulnerability in the 'setitimer(2)' system call. The vulnerability likely stems from an error in handling signed integers. Exploiting this vulnerability may allow local attackers to write to kernel memory and obtain root privileges.

Other BSD-based operating systems are likely vulnerable.

- 漏洞利用

Core Security Technologies has developed a working commercial exploit for its CORE IMPACT product. This exploit is not otherwise publicly available or known to be circulating in the wild.

- 解决方案

OpenBSD has made available source code patches for OpenBSD 3.1 and 3.0.

OpenBSD OpenBSD 3.0

OpenBSD OpenBSD 3.1

- 相关参考