CVE-2002-2178
CVSS4.3
发布时间 :2002-12-31 00:00:00
修订时间 :2008-09-05 16:32:32
NMCOE    

[原文]Cross-site scripting (XSS) vulnerability in article.php module for phpWebSite 0.8.3 allows remote attackers to execute arbitrary Javascript script via the sid parameter, as demonstrated using an IMG tag.


[CNNVD]PHPWebSite Article.PHP跨站脚本漏洞(CNNVD-200212-539)

        phpWebSite 0.8.3版本的article.php模块存在跨站脚本(XSS)漏洞。远程攻击者可以借助sid参数执行任意Javascript脚本,正如使用IMG标签。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-2178
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-2178
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200212-539
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/5864
(VENDOR_ADVISORY)  BID  5864
http://www.securityfocus.com/archive/1/293879
(UNKNOWN)  BUGTRAQ  20021002 phpWebSite XSS Vulnerability
http://www.iss.net/security_center/static/10256.php
(VENDOR_ADVISORY)  XF  phpwebsite-img-article-xss(10256)

- 漏洞信息

PHPWebSite Article.PHP跨站脚本漏洞
中危 跨站脚本
2002-12-31 00:00:00 2006-03-03 00:00:00
远程  
        phpWebSite 0.8.3版本的article.php模块存在跨站脚本(XSS)漏洞。远程攻击者可以借助sid参数执行任意Javascript脚本,正如使用IMG标签。

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com .

- 漏洞信息 (21864)

PHPWebSite 0.8.3 News Message HTML Injection Vulnerability (EDBID:21864)
php webapps
2002-09-25 Verified
0 das@hush.com
N/A [点击下载]
source: http://www.securityfocus.com/bid/5802/info

Problems with phpWebSite could make it possible to execute arbitrary script code in a vulnerable client.

phpWebSite does not sufficiently filter potentially malicious HTML code from news posts. As a result, when a user views a news posting that contains malicious HTML code, the code contained in the posted message would be executed in the browser of the vulnerable user. This will occur in the context of the site running the phpWebSite software. 

<IMG SRC="javascript:alert('unsecure')"> 		

- 漏洞信息 (21899)

PHPWebSite 0.8.3 Article.PHP Cross-Site Scripting Vulnerability (EDBID:21899)
php webapps
2002-10-02 Verified
0 Sp.IC
N/A [点击下载]
source: http://www.securityfocus.com/bid/5864/info

phpWebSite is prone to cross-site scripting attacks.

This vulnerability is due to insufficient sanitization of HTML tags from URI parameters processed by the 'article.php' script. As a result, an attacker may construct a malicious link to this script which contains arbitrary HTML and script code.

When the malicious link is visited by a web user, the attacker-supplied code will be executed by their web client in the context of the site hosting the vulnerable software.

http://target/article.php?sid="><Img Src=javascript:alert(document.cookie)><Img Src="		

- 漏洞信息

3850
phpWebSite article.php sid Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

phpWebSite contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate HTML Tags upon submission to the article.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2002-10-02 Unknow
2002-10-02 Unknow

- 解决方案

Upgrade to version 0.9.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站