CVE-2002-2140
CVSS5.0
发布时间 :2002-12-31 00:00:00
修订时间 :2008-09-05 16:32:26
NMCO    

[原文]Buffer overflow in Cisco PIX Firewall 5.2.x to 5.2.8, 6.0.x to 6.0.3, 6.1.x to 6.1.3, and 6.2.x to 6.2.1 allows remote attackers to cause a denial of service via HTTP traffic authentication using (1) TACACS+ or (2) RADIUS.


[CNNVD]Cisco PIX TACACS+/RADIUS HTTP代理缓冲区溢出漏洞(CNNVD-200212-684)

        
        Cisco PIX防火墙提供企业级安全服务,包括状态检测防火墙、IPSEC、VPN、入侵检测等功能。
        Cisco PIX防火墙HTTP RADIUS/TACACS+代理组件对用户畸形请求处理不正确,远程攻击者可以利用这个漏洞进行缓冲区溢出攻击,导致设备重启。
        用户通过FTP,TELNET或者HTTP启动连接,会提示输入它们的用户名和密码,如果用户名和密码由指定的TACACS+或RADIUS验证服务器校验,PIX防火墙会允许通过防火墙的"cut-through proxy"功能在验证服务器和连接端进行更多的通信。
        不过PIX防火墙对用户提交的畸形HTTP请求处理存在问题,可导致由于缓冲区溢出而使PIX崩溃。
        CISCO指定此漏洞BUG ID为:CSCdx35823
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:cisco:pix_firewall:5.2
cpe:/o:cisco:pix_firewall:5.2%284%29
cpe:/o:cisco:pix_firewall:6.1%281%29
cpe:/o:cisco:pix_firewall:6.0%281%29
cpe:/o:cisco:pix_firewall:5.2%282%29
cpe:/o:cisco:pix_firewall:6.2
cpe:/o:cisco:pix_firewall:6.0
cpe:/o:cisco:pix_firewall:5.2%285%29
cpe:/o:cisco:pix_firewall:5.2%287%29
cpe:/o:cisco:pix_firewall:6.2%281%29
cpe:/o:cisco:pix_firewall:6.0%283%29
cpe:/o:cisco:pix_firewall:6.1%283%29
cpe:/o:cisco:pix_firewall:5.2%286%29
cpe:/o:cisco:pix_firewall:6.1%282%29
cpe:/o:cisco:pix_firewall:5.2%281%29
cpe:/o:cisco:pix_firewall:6.0%282%29
cpe:/o:cisco:pix_firewall:6.1
cpe:/o:cisco:pix_firewall:5.2%288%29
cpe:/o:cisco:pix_firewall:5.2%283%29

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-2140
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-2140
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200212-684
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/6212
(PATCH)  BID  6212
http://www.iss.net/security_center/static/10661.php
(PATCH)  XF  cisco-pix-http-dos(10661)
http://www.cisco.com/warp/public/707/pix-multiple-vuln-pub.shtml
(PATCH)  CISCO  20021120 Cisco PIX Multiple Vulnerabilities
http://www.ciac.org/ciac/bulletins/n-017.shtml
(PATCH)  CIAC  N-017

- 漏洞信息

Cisco PIX TACACS+/RADIUS HTTP代理缓冲区溢出漏洞
中危 边界条件错误
2002-12-31 00:00:00 2006-01-27 00:00:00
远程  
        
        Cisco PIX防火墙提供企业级安全服务,包括状态检测防火墙、IPSEC、VPN、入侵检测等功能。
        Cisco PIX防火墙HTTP RADIUS/TACACS+代理组件对用户畸形请求处理不正确,远程攻击者可以利用这个漏洞进行缓冲区溢出攻击,导致设备重启。
        用户通过FTP,TELNET或者HTTP启动连接,会提示输入它们的用户名和密码,如果用户名和密码由指定的TACACS+或RADIUS验证服务器校验,PIX防火墙会允许通过防火墙的"cut-through proxy"功能在验证服务器和连接端进行更多的通信。
        不过PIX防火墙对用户提交的畸形HTTP请求处理存在问题,可导致由于缓冲区溢出而使PIX崩溃。
        CISCO指定此漏洞BUG ID为:CSCdx35823
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 暂时关闭PIX防火墙的HTTP服务。
        厂商补丁:
        Cisco
        -----
        Cisco已经为此发布了一个安全公告(Cisco-pix-multiple)以及相应补丁:
        Cisco-pix-multiple:Cisco PIX Multiple Vulnerabilities
        链接:
        http://www.cisco.com/warp/public/707/pix-multiple-vuln-pub.shtml

        补丁下载:
        升级程序如下,详情请见:
        
        http://www.cisco.com/univercd/cc/td/doc/product/iaabu/pix/pix_sw/index.htm.

        签约用户可从正常更新渠道获取升级软件。对大多数用户来说,可通过Cisco网站软件中心获取升级软件:
        
        http://www.cisco.com/pcgi-bin/tablebuild.pl/pix

        要访问软件,下载URL:
        
        http://www.cisco.com/pcgi-bin/tablebuild.pl/pix

        不过你需要是注册用户和必须登录才能访问。
        事先或目前与第三方支持组织,如Cisco合作伙伴、授权零售商或服务商之间已有协议,由第三方组织提供Cisco产品或技术支持的用户可免费获得升级支持。
        直接从Cisco购买产品但没有Cisco服务合同的用户和由第三方厂商购买产品但无法从销售方获得已修复软件的用户可从Cisco技术支持中心(TAC)获取升级软件。TAC联系方法:
         * +1 800 553 2447 (北美地区免话费)
         * +1 408 526 7209 (全球收费)
         * e-mail: tac@cisco.com
        
        查看
        http://www.cisco.com/warp/public/687/Directory/DirTAC.shtml
获取额外的TAC联系信息,包括特别局部的电话号码,各种语言的指南和EMAIL地址。

- 漏洞信息

60070
Cisco PIX Firewall Multiple Method HTTP Authentication Remote DoS
Remote / Network Access Denial of Service
Loss of Availability Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2002-11-20 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 5.2.9, 6.0.4, 6.1.4 or 6.2.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站