发布时间 :2002-12-31 00:00:00
修订时间 :2008-09-05 16:32:20

[原文]PHP remote file inclusion vulnerability in WikkiTikkiTavi before 0.21 allows remote attackers to execute arbitrary PHP code via the TemplateDir variable, as demonstrated using conflict.php.


        WikkiTikkiTavi 0.21之前版本存在PHP远程文件包含漏洞。远程攻击者可以借助TemplateDir变量执行任意PHP代码,正如使用conflict.php。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(PATCH)  XF  wikkitikkitavi-include-template(8001)
(PATCH)  BID  3946
(PATCH)  SECTRACK  1003307
(VENDOR_ADVISORY)  MLIST  [tavi-devel] 20020102 "Tavi security advisory

- 漏洞信息

高危 输入验证
2002-12-31 00:00:00 2005-10-20 00:00:00
        WikkiTikkiTavi 0.21之前版本存在PHP远程文件包含漏洞。远程攻击者可以借助TemplateDir变量执行任意PHP代码,正如使用conflict.php。

- 公告与补丁

        The vendor has addressed this issue in versions 0.21 and later.
        WikkiTikkiTavi WikkiTikkiTavi 0.10
        WikkiTikkiTavi WikkiTikkiTavi 0.20
        WikkiTikkiTavi WikkiTikkiTavi 0.5

- 漏洞信息 (21241)

WikkiTikkiTavi 0.x Remote File Include Vulnerability (EDBID:21241)
php webapps
2002-01-02 Verified
0 Scott Moonen
N/A [点击下载]

WikkiTikkiTavi is a freely available engine for running a Wiki site. Wiki sites are web communities which are based on the idea that every webpage is editable by users of the website. WikkiTikkiTavi is back-ended by a MySQL database and runs on most Linux and Unix variants, as well as Microsoft Windows NT/2000 operating systems.

WikkiTikkiTavi permits remote file including. As a result, a remote attacker may include an arbitrary file located on a remote host. This may be exploited via a malicious web request. If this file is a PHP script, it will be executed on the host running the vulnerable software with the privileges of the webserver.

The attacker may use this as an opportunity to gain local access on the host running the vulnerable software.

The following URL is sufficient to exploit this issue:

where conflict.php is the name of the malicious attacker-supplied script. 		

- 漏洞信息

WikkiTikkiTavi conflict.php TemplateDir Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Public Vendor Verified, Third-party Verified

- 漏洞描述

WikkiTikkiTavi contains a flaw that may allow a remote attacker to execute arbitrary commands or code. The issue is due to the 'conflict.php' script not properly sanitizing user input supplied to the 'TemplateDir' parameter. This may allow an attacker to include a file from a third-party remote host that contains commands or code that will be executed by the vulnerable script with the same privileges as the web server.

- 时间线

2002-01-02 Unknow
2002-01-02 Unknow

- 解决方案

Upgrade to version 0.21 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete