CVE-2002-2096
CVSS7.5
发布时间 :2002-12-31 00:00:00
修订时间 :2008-09-05 16:32:19
NMCO    

[原文]Buffer overflow in Novell Remote Manager module, httpstk.nlm, in NetWare 5.1 and NetWare 6 allows remote attackers to execute arbitrary code via a long (1) username or (2) password.


[CNNVD]Netware远程管理验证存在缓冲区溢出漏洞(CNNVD-200212-160)

        
        Novell Netware远程管理器为Novell产品提供基于WEB的管理员接口,远程管理器默认接收端口为8009的SSL连接。
        Novell Netware远程管理器验证处理上存在漏洞,可导致远程攻击者提交超长字符串导致缓冲溢出。
        攻击者可以通过连接8009端口,在HTTP基本验证中的用户名和密码字段提交超长的字符串,可导致缓冲溢出发生,根据提交字符串长度的不同,SERVER.NLM 或者HTTPSTK.NLM模块进程都会出现异常终止,导致拒绝服务攻击。
        存在任意代码以服务器进程权限执行的可能性,但尚未证实。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:novell:netware:6.0Novell NetWare 6.0
cpe:/o:novell:netware:5.1Novell NetWare 5.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-2096
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-2096
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200212-160
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/4405
(PATCH)  BID  4405
http://www.iss.net/security_center/static/8736.php
(PATCH)  XF  netware-remote-manager-bo(8736)
http://support.novell.com/servlet/tidfinder/2962026
(VENDOR_ADVISORY)  CONFIRM  http://support.novell.com/servlet/tidfinder/2962026
http://archives.neohapsis.com/archives/bugtraq/2002-04/0088.html
(PATCH)  BUGTRAQ  20020406 NetWare Remote Manager patches
http://archives.neohapsis.com/archives/bugtraq/2002-04/0001.html
(VENDOR_ADVISORY)  BUGTRAQ  20020402 iXsecurity.20020313.nw6remotemanager.a

- 漏洞信息

Netware远程管理验证存在缓冲区溢出漏洞
高危 边界条件错误
2002-12-31 00:00:00 2005-10-20 00:00:00
远程  
        
        Novell Netware远程管理器为Novell产品提供基于WEB的管理员接口,远程管理器默认接收端口为8009的SSL连接。
        Novell Netware远程管理器验证处理上存在漏洞,可导致远程攻击者提交超长字符串导致缓冲溢出。
        攻击者可以通过连接8009端口,在HTTP基本验证中的用户名和密码字段提交超长的字符串,可导致缓冲溢出发生,根据提交字符串长度的不同,SERVER.NLM 或者HTTPSTK.NLM模块进程都会出现异常终止,导致拒绝服务攻击。
        存在任意代码以服务器进程权限执行的可能性,但尚未证实。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 对服务端口8009设置访问过滤,确信只有合法可信的用户能够连接访问。
        厂商补丁:
        Novell
        ------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.novell.com/

- 漏洞信息

19752
Novell NetWare Remote Manager httpstk.nlm Multiple Field Remote Overflow
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

A remote overflow exists in Novell NetWare. The 'HTTPSTK.NLM' module of the NetWare Remote Manager fails to perform proper bounds checking resulting in a buffer overflow. With a specially crafted request containing an overly long username or password, a remote attacker can cause arbitrary code execution resulting in a loss of integrity.

- 时间线

2002-04-02 2002-03-14
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Novell has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站