CVE-2002-2086
CVSS4.3
发布时间 :2002-12-31 00:00:00
修订时间 :2008-09-05 16:32:17
NMCO    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in magicHTML of SquirrelMail before 1.2.6 allow remote attackers to inject arbitrary web script or HTML via (1) "<<script" in unspecified input fields or (2) a javascript: URL in the src attribute of an IMG tag.


[CNNVD]SquirrelMail HTML附件可插入脚本漏洞(CNNVD-200212-439)

        
        SquirrelMail是一款由PHP实现的WEBMAIL程序,可使用在多种Linux和Unix操作系统下。
        SquirrelMail对HTML文件附件的数据缺少充分正确的检查,可导致攻击者进行跨站脚本执行攻击。
        攻击者可以在SquirrelMail的HTML文件附件输入包含恶意脚本代码,由于SquirrelMail在HTML文件中的内容没有对脚本代码标记进行过滤,用户查看包含恶意代码的HTML邮件时,可导致代码在浏览用户浏览器上执行,使用户基于Cookie认证的敏感信息泄露。
        

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:squirrelmail:squirrelmail:1.2.0
cpe:/a:squirrelmail:squirrelmail:1.2.1
cpe:/a:squirrelmail:squirrelmail:1.2.2
cpe:/a:squirrelmail:squirrelmail:1.2.4
cpe:/a:squirrelmail:squirrelmail:1.2.5
cpe:/a:squirrelmail:squirrelmail:1.2.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-2086
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-2086
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200212-439
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/9009
(PATCH)  XF  squirrelmail-html-attachment-xss(9009)
http://xforce.iss.net/xforce/xfdb/9008
(PATCH)  XF  squirrelmail-header-xss(9008)
http://www.securityfocus.com/bid/4667
(PATCH)  BID  4667
http://www.securityfocus.com/bid/4666
(PATCH)  BID  4666
http://www.squirrelmail.org/changelog.php
(UNKNOWN)  CONFIRM  http://www.squirrelmail.org/changelog.php
http://sourceforge.net/tracker/index.php?func=detail&aid=545933&group_id=311&atid=100311
(VENDOR_ADVISORY)  CONFIRM  http://sourceforge.net/tracker/index.php?func=detail&aid=545933&group_id=311&atid=100311
http://sourceforge.net/tracker/index.php?func=detail&aid=544658&group_id=311&atid=100311
(VENDOR_ADVISORY)  CONFIRM  http://sourceforge.net/tracker/index.php?func=detail&aid=544658&group_id=311&atid=100311

- 漏洞信息

SquirrelMail HTML附件可插入脚本漏洞
中危 输入验证
2002-12-31 00:00:00 2006-04-07 00:00:00
远程  
        
        SquirrelMail是一款由PHP实现的WEBMAIL程序,可使用在多种Linux和Unix操作系统下。
        SquirrelMail对HTML文件附件的数据缺少充分正确的检查,可导致攻击者进行跨站脚本执行攻击。
        攻击者可以在SquirrelMail的HTML文件附件输入包含恶意脚本代码,由于SquirrelMail在HTML文件中的内容没有对脚本代码标记进行过滤,用户查看包含恶意代码的HTML邮件时,可导致代码在浏览用户浏览器上执行,使用户基于Cookie认证的敏感信息泄露。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 修改程序,严格过滤用户输入的数据,不允许JavaScript脚本或对<>字符进行转换。
        * 设置浏览器禁用JavaScript。
        厂商补丁:
        SquirrelMail
        ------------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        升级程序到squirrelmail-1.2.6版本:
        SquirrelMail Upgrade squirrelmail-1.2.6
        
        http://www.squirrelmail.org/download.php

- 漏洞信息

59456
SquirrelMail HTML File Attachment Handling XSS
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2002-04-16 Unknow
Unknow 2002-04-29

- 解决方案

Upgrade to version 1.2.6 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站