CVE-2002-2047
CVSS10.0
发布时间 :2002-12-31 00:00:00
修订时间 :2008-09-05 16:32:11
NMCO    

[原文]The file preview functionality in Sketch 0.6.12 and earlier allows remote attackers to execute arbitrary commands via shell metacharacters in the filename of an encapsulated Postscript (EPS) file.


[CNNVD]Sketch任意Shell命令执行漏洞(CNNVD-200212-206)

        Sketch 0.6.12及其早期版本中的文件预览性能存在漏洞。远程攻击者可以通过封装的PostScript(EPS)文件的文件名中的shell元字符执行任意命令。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-2047
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-2047
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200212-206
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/4296
(PATCH)  BID  4296
http://www.iss.net/security_center/static/8469.php
(PATCH)  XF  sketch-eps-command-execution(8469)
http://securitytracker.com/id?1003818
(PATCH)  SECTRACK  1003818

- 漏洞信息

Sketch任意Shell命令执行漏洞
危急 输入验证
2002-12-31 00:00:00 2005-10-20 00:00:00
远程  
        Sketch 0.6.12及其早期版本中的文件预览性能存在漏洞。远程攻击者可以通过封装的PostScript(EPS)文件的文件名中的shell元字符执行任意命令。

- 公告与补丁

        The vendor has released Sketch 0.6.13:
        Sketch Sketch 0.6.12
        

- 漏洞信息

60027
Sketch File Preview Functionality EPS Filename Shell Metacharacter Arbitrary Command Execution
Input Manipulation
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2002-02-07 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.6.13 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站