CVE-2002-2032
CVSS5.0
发布时间 :2002-12-31 00:00:00
修订时间 :2008-09-05 16:32:09
NMCOE    

[原文]sql_layer.php in PHP-Nuke 5.4 and earlier does not restrict access to debugging features, which allows remote attackers to gain SQL query information by setting the sql_debug parameter to (1) index.php and (2) modules.php.


[CNNVD]PHP-Nuke SQL_Debug调试信息泄露漏洞(CNNVD-200212-243)

        
        PHP-Nuke是一个网站创建和管理工具,它可以用很多数据库软件作为后端,比如MySQL、PostgreSQL、mSQL、Interbase、Sybase等。
        PHP-Nuke在脚本中的调试信息处理存在问题,可以使远程攻击者得到数据库查询请求的一些敏感信息。
        sql_layer.php脚本有一个调试功能可以被攻击者利用来获得所有PHP-Nuke的查询请求信息。对调试功能的访问并不只限于管理员。远程攻击者可能利用这个漏洞得到数据库相关的敏感信息并进一步攻击数据库所在的Web服务器。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:francisco_burzi:php-nuke:1.0
cpe:/a:francisco_burzi:php-nuke:5.0.1
cpe:/a:francisco_burzi:php-nuke:5.1
cpe:/a:francisco_burzi:php-nuke:5.0
cpe:/a:francisco_burzi:php-nuke:4.3
cpe:/a:francisco_burzi:php-nuke:3.0
cpe:/a:francisco_burzi:php-nuke:5.2a
cpe:/a:francisco_burzi:php-nuke:5.2
cpe:/a:francisco_burzi:php-nuke:4.4.1a
cpe:/a:francisco_burzi:php-nuke:5.4
cpe:/a:francisco_burzi:php-nuke:4.0
cpe:/a:francisco_burzi:php-nuke:4.4
cpe:/a:francisco_burzi:php-nuke:5.3.1
cpe:/a:francisco_burzi:php-nuke:2.5

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-2032
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-2032
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200212-243
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/3906
(UNKNOWN)  BID  3906
http://www.securityfaq.com/unixfocus/5OP041P6BE.html
(UNKNOWN)  MISC  http://www.securityfaq.com/unixfocus/5OP041P6BE.html

- 漏洞信息

PHP-Nuke SQL_Debug调试信息泄露漏洞
中危 设计错误
2002-12-31 00:00:00 2005-10-20 00:00:00
远程  
        
        PHP-Nuke是一个网站创建和管理工具,它可以用很多数据库软件作为后端,比如MySQL、PostgreSQL、mSQL、Interbase、Sybase等。
        PHP-Nuke在脚本中的调试信息处理存在问题,可以使远程攻击者得到数据库查询请求的一些敏感信息。
        sql_layer.php脚本有一个调试功能可以被攻击者利用来获得所有PHP-Nuke的查询请求信息。对调试功能的访问并不只限于管理员。远程攻击者可能利用这个漏洞得到数据库相关的敏感信息并进一步攻击数据库所在的Web服务器。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 关闭SQL调试功能。
        厂商补丁:
        Francisco Burzi
        ---------------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.phpnuke.org

- 漏洞信息 (21233)

PHPNuke 4.x/5.x SQL_Debug Information Disclosure Vulnerability (EDBID:21233)
php webapps
2002-01-18 Verified
0 zataz.com
N/A [点击下载]
source: http://www.securityfocus.com/bid/3906/info

PHPNuke is a website creation/maintenance tool. It is can be back-ended by a number of database products such as MySQL, PostgreSQL, mSQL, Interbase, Sybase, etc.

The sql_layer.php script contains a debugging feature that may be used by attackers to disclose sensitive information about all SQL queries made by PHPNuke. Access to the debugging feature is not restricted to administrators.

This may be used by a remote attacker to disclose sensitive information about the database which may contribute to further attacks against the website running PHPNuke and the database.

It is not known whether PostNuke is also affected by this issue. 

The following URLs may be used to access the debugging features:

http://www.vulnerable-site.com/index.php?sql_debug=1

or

http://www.vulnerable-site.com/modules.php?name=Members_List&&sql_debug=1


		

- 漏洞信息

713
PHP-Nuke sql_layer.php sql_debug Parameter Information Disclosure
Remote / Network Access Information Disclosure
Loss of Confidentiality Upgrade
Exploit Public Third-party Verified

- 漏洞描述

PHP-Nuke contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the 'sql_layer.php' script not properly sanitizing user-supplied input to the 'sql_debug' parameter. This may allow an attacker to inject or manipulate SQL queries in the back-end database, allowing for the manipulation or disclosure of arbitrary data.

- 时间线

2002-01-18 Unknow
2002-01-18 Unknow

- 解决方案

Upgrade to version PHP-Nuke 5.5 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站