CVE-2002-2011
CVSS4.3
发布时间 :2002-12-31 00:00:00
修订时间 :2008-09-05 16:32:05
NMCOE    

[原文]Cross-site scripting (XSS) vulnerability in the fom CGI program (fom.cgi) in Faq-O-Matic 2.711 and 2.712 allows remote attackers to inject arbitrary web script or HTML via the file parameter.


[CNNVD]Faq-O-Matic跨站脚本执行漏洞(CNNVD-200212-287)

        
        Faq-O-Matic是一款基于WEB的FAQ管理系统,可运行在多种Linux和Unix操作系统下。
        Faq-O-Matic对用户提交给URL的数据没有正确充分的处理,导致攻击者可以进行跨站脚本攻击。
        Faq-O-Maticde中的fom.cgi脚本没有正确检查用户提交给"file"参数的内容,如果"file"参数的内容不存在,脚本就会把错误信息打印成HTML形式,攻击者可以在"file"参数中插入恶意脚本代码,当其他用户查看此连接时,就可以导致其中的脚本代码在用户浏览器上执行,导致基于Cookie认证的信息被泄露等问题。
        

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:jon_howell:faq-o-matic:2.712
cpe:/a:jon_howell:faq-o-matic:2.711

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-2011
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-2011
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200212-287
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/4565
(UNKNOWN)  BID  4565
http://www.iss.net/security_center/static/8906.php
(UNKNOWN)  XF  faqomatic-cgi-file-css(8906)
http://archives.neohapsis.com/archives/bugtraq/2002-04/0287.html
(UNKNOWN)  BUGTRAQ  20020419 Another Faq-O-Matic XSS Vuln?

- 漏洞信息

Faq-O-Matic跨站脚本执行漏洞
中危 输入验证
2002-12-31 00:00:00 2005-10-20 00:00:00
远程  
        
        Faq-O-Matic是一款基于WEB的FAQ管理系统,可运行在多种Linux和Unix操作系统下。
        Faq-O-Matic对用户提交给URL的数据没有正确充分的处理,导致攻击者可以进行跨站脚本攻击。
        Faq-O-Maticde中的fom.cgi脚本没有正确检查用户提交给"file"参数的内容,如果"file"参数的内容不存在,脚本就会把错误信息打印成HTML形式,攻击者可以在"file"参数中插入恶意脚本代码,当其他用户查看此连接时,就可以导致其中的脚本代码在用户浏览器上执行,导致基于Cookie认证的信息被泄露等问题。
        

- 公告与补丁

        厂商补丁:
        Jon Howell
        ----------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://faqomatic.sourceforge.net/

- 漏洞信息 (21405)

Jon Howell Faq-O-Matic 2.7 Cross Site Scripting Vulnerability (EDBID:21405)
cgi webapps
2002-04-20 Verified
0 BrainRawt
N/A [点击下载]
source: http://www.securityfocus.com/bid/4565/info

Faq-O-Matic 2.711 and 2.712 is a web-based Frequently Asked Question (FAQ) management system. It is vulnerable to a cross site scripting issue arising from a failure to filter HTML or script from a malformed query, returning the submitted script as an error message which is then processed by the browser. This is done by submitting the script as an argument to the Faq-O-Matic component "fom.cgi" - specifically, to the "file" parameter. This script is then treated by the user's browser as though it originated from the Faq-O-Matic web site.

http://www.wherever.tld/path_to_Faq-O-Matic/fom?file=<script>alert('If+this+script+was+modified,+it+could+easily+steal+amigadev.net+cookies+and+log+them+to+a+remote+location')</script>&step
		

- 漏洞信息

54110
Faq-O-Matic fom.cgi file Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity Solution Unknown

- 漏洞描述

- 时间线

2002-04-19 Unknow
Unknow Unknow

- 解决方案

OSVDB is not aware of a solution for this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站