CVE-2002-1995
CVSS4.3
发布时间 :2002-12-31 00:00:00
修订时间 :2008-09-05 16:32:03
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in phptonuke.php for PHP-Nuke allows remote attackers to inject arbitrary web script or HTML via the filnavn parameter.


[CNNVD]PHP-Nuke附件PHPToNuke.PHP跨站脚本执行漏洞(CNNVD-200212-601)

        
        phptonuke.php是一个PHP-Nuke附加脚本,用于把一段PHP脚本插入到一个PHP-Nuke站点,程序由Lebios维护。
        phptonuke.php存在跨站脚本执行漏洞,可以使攻击者在被攻击者的浏览器上下文执行脚本。
        攻击者可能利用phptonuke.php创建一个含有脚本代码的链接,当用户访问这个链接时,脚本会在用户机器浏览器上在当前用户环境下执行。攻击者可能利用这个问题劫持基于Cookie验证的用户会话。
        

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1995
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1995
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200212-601
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/3807
(UNKNOWN)  BID  3807
http://www.iss.net/security_center/static/7837.php
(UNKNOWN)  XF  phpnuke-phptonuke-css(7837)
http://archives.neohapsis.com/archives/vuln-dev/2002-q1/0048.html
(UNKNOWN)  VULN-DEV  20020106 CSS in PHPNuke add-on

- 漏洞信息

PHP-Nuke附件PHPToNuke.PHP跨站脚本执行漏洞
中危 输入验证
2002-12-31 00:00:00 2005-10-20 00:00:00
远程  
        
        phptonuke.php是一个PHP-Nuke附加脚本,用于把一段PHP脚本插入到一个PHP-Nuke站点,程序由Lebios维护。
        phptonuke.php存在跨站脚本执行漏洞,可以使攻击者在被攻击者的浏览器上下文执行脚本。
        攻击者可能利用phptonuke.php创建一个含有脚本代码的链接,当用户访问这个链接时,脚本会在用户机器浏览器上在当前用户环境下执行。攻击者可能利用这个问题劫持基于Cookie验证的用户会话。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 在浏览器中设置禁止Java脚本及活动脚本的执行。
        厂商补丁:
        Lebios
        ------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.phpnuke.org/

- 漏洞信息

59093
PHP-Nuke phptonuke.php filnavn Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity Solution Unknown
Exploit Public Third-party Verified, Uncoordinated Disclosure

- 漏洞描述

PHP-Nuke contains a flaw that allows a remote cross site scripting (XSS) attack. This flaw exists because the application does not validate the 'filnavn' parameter upon submission to the 'phptonuke.php' script. This may allow a user to create a specially crafted URL that would execute arbitrary script code in a user's browser within the trust relationship between their browser and the server.

- 时间线

2002-01-06 Unknow
2002-01-06 Unknow

- 解决方案

Currently, there are no known upgrades, patches or workarounds available to correct this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站