CVE-2002-1966
CVSS5.0
发布时间 :2002-12-31 00:00:00
修订时间 :2008-09-05 16:31:58
NMCOE    

[原文]Directory traversal vulnerability in magiccard.cgi in My Postcards Platinum 5.0 and 6.0 allows remote attackers to read arbitrary files via a .. (dot dot) in the page parameter.


[CNNVD]My Postcards MagicCard.CGI远程文件泄露漏洞(CNNVD-200212-749)

        
        My Postcards是一款商业电子贺卡系统,可使用在多种Unix和Linux操作系统下。
        My Postcards中的magiccard.cgi脚本处理用户输入时缺少正确检查,远程攻击者可以利用这个漏洞进行目录遍历攻击。
        magiccard.cgi脚本page参数对用户提交的数据缺少过滤,远程攻击者可以提交包含多个'../'字符并追加系统文件名的请求,而导致以WEB进程权限查看目标系统上任意文件内容,造成敏感信息泄露。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:my_postcards:my_postcards_platinum:6.0
cpe:/a:my_postcards:my_postcards_platinum:5.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1966
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1966
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200212-749
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/5029
(UNKNOWN)  BID  5029
http://www.securiteam.com/unixfocus/5IP0G2K7FQ.html
(UNKNOWN)  MISC  http://www.securiteam.com/unixfocus/5IP0G2K7FQ.html
http://packetstormsecurity.nl/0206-exploits/magiccard_vuln.txt
(UNKNOWN)  MISC  http://packetstormsecurity.nl/0206-exploits/magiccard_vuln.txt

- 漏洞信息

My Postcards MagicCard.CGI远程文件泄露漏洞
中危 输入验证
2002-12-31 00:00:00 2005-10-20 00:00:00
远程  
        
        My Postcards是一款商业电子贺卡系统,可使用在多种Unix和Linux操作系统下。
        My Postcards中的magiccard.cgi脚本处理用户输入时缺少正确检查,远程攻击者可以利用这个漏洞进行目录遍历攻击。
        magiccard.cgi脚本page参数对用户提交的数据缺少过滤,远程攻击者可以提交包含多个'../'字符并追加系统文件名的请求,而导致以WEB进程权限查看目标系统上任意文件内容,造成敏感信息泄露。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 修改程序,严格过滤用户输入数据。
        厂商补丁:
        My Postcards
        ------------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://mypostcards.com/platinum/

- 漏洞信息 (21558)

My Postcards 6.0 MagicCard.CGI Arbitrary File Disclosure Vulnerability (EDBID:21558)
cgi webapps
2002-06-15 Verified
0 cult
N/A [点击下载]
source: http://www.securityfocus.com/bid/5029/info

My Postcards is a commercial available eletronic postcard system. It is available for Unix and Linux Operating Systems.

The magiccard.cgi script does not properly handle some types of input. As a result, it may be possible for a remote user to specify the location of a specific file on the system hosting the My Postcards software. Upon specifying the location of a file that is readable by the web server process, the user could disclose the contents of the specified file. 

http://www.example.com/cgi-bin/magiccard.cgi?pa=3Dpreview&next=3Dcustom&page=3D../../../../../../../../../../etc/passwd 		

- 漏洞信息

39356
My Postcards Platinum magiccard.cgi Directory Traversal
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality

- 漏洞描述

My Postcards Platinum contains a flaw that allows a remote attacker to read contents outside of the web path. The issue is due to the 'magiccard.cgi' not properly sanitizing user input, specifically directory traversal style attacks (../../) supplied via unspecified variables.

- 时间线

2002-06-05 Unknow
Unknow Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站