CVE-2002-1959
CVSS10.0
发布时间 :2002-12-31 00:00:00
修订时间 :2008-09-05 16:31:57
NMCO    

[原文]Nagios 1.0b1 through 1.0b3 allows remote attackers to execute arbitrary commands via shell metacharacters in plugin output.


[CNNVD]Nagios插件SHELL字符远程任意命令执行漏洞(CNNVD-200212-701)

        
        Nagios是一款免费开放源代码的主机和服务监视软件,可使用在多种Linux和Unix操作系统下。
        Nagios服务程序对插件发送的恶意数据缺少正确的过滤,远程攻击者可以利用这个漏洞在系统上以Nagios进程的权限在系统上执行任意命令。
        攻击者可以产生一事件引起插件发送恶意格式的数据给Nagios服务器,由于Nagios服务程序对包含的数据缺少正确的过滤,如果数据中包含元字符和任意命令,当接收解析这个数据时,包含在元字符之间的任意命令将以Nagios进程的权限在系统上执行。
        <**>

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:nagios:nagios:1.0_b3
cpe:/a:nagios:nagios:1.0_b1
cpe:/a:nagios:nagios:1.0_b2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1959
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1959
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200212-701
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/5174
(PATCH)  BID  5174
http://www.iss.net/security_center/static/9508.php
(PATCH)  XF  nagios-plugin-command-execution(9508)
http://www.nagios.org/changelog.php
(UNKNOWN)  CONFIRM  http://www.nagios.org/changelog.php

- 漏洞信息

Nagios插件SHELL字符远程任意命令执行漏洞
危急 输入验证
2002-12-31 00:00:00 2005-10-20 00:00:00
远程  
        
        Nagios是一款免费开放源代码的主机和服务监视软件,可使用在多种Linux和Unix操作系统下。
        Nagios服务程序对插件发送的恶意数据缺少正确的过滤,远程攻击者可以利用这个漏洞在系统上以Nagios进程的权限在系统上执行任意命令。
        攻击者可以产生一事件引起插件发送恶意格式的数据给Nagios服务器,由于Nagios服务程序对包含的数据缺少正确的过滤,如果数据中包含元字符和任意命令,当接收解析这个数据时,包含在元字符之间的任意命令将以Nagios进程的权限在系统上执行。
        <**>

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 暂时没有合适的临时解决方法。
        厂商补丁:
        Nagios
        ------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        Nagios Upgrade nagios-1.0b4.tar.gz
        
        http://prdownloads.sourceforge.net/nagios/nagios-1.0b4.tar.gz?download

- 漏洞信息

59585
Nagios Plugin Output Shell Metacharacter Arbitrary Command Execution
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2002-07-04 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.0b4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站