CVE-2002-1868
CVSS10.0
发布时间 :2002-12-31 00:00:00
修订时间 :2008-09-05 16:31:43
NMCOE    

[原文]Dispair 0.1 and 0.2 allows remote attackers to execute arbitrary shell commands via certain form fields.


[CNNVD]Dispair远程命令执行漏洞(CNNVD-200212-706)

        Dispair 0.1和0.2版本存在漏洞。远程攻击者借助某些表单字段执行任意shell命令。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:daniel_stenberg:dispair:0.1
cpe:/a:daniel_stenberg:dispair:0.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1868
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1868
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200212-706
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/5392
(PATCH)  BID  5392
http://www.iss.net/security_center/static/9787.php
(PATCH)  XF  dispair-execute-commands(9787)

- 漏洞信息

Dispair远程命令执行漏洞
危急 输入验证
2002-12-31 00:00:00 2005-10-20 00:00:00
远程  
        Dispair 0.1和0.2版本存在漏洞。远程攻击者借助某些表单字段执行任意shell命令。

- 公告与补丁

        The vendor has addressed this issue in Dispair 0.3.
        Daniel Stenberg Dispair 0.1
        
        Daniel Stenberg Dispair 0.2
        

- 漏洞信息 (21679)

Dispair 0.1/0.2 Remote Command Execution Vulnerability (EDBID:21679)
cgi webapps
2002-07-30 Verified
0 Anonymous
N/A [点击下载]
source: http://www.securityfocus.com/bid/5392/info

Dispair fails to sufficiently validate user-supplied input before it is passed to the shell via the Perl open() function. Remote attackers may potentially exploit this issue to execute arbitrary commands on the underlying shell with the privileges of the webserver process.

http://target/cgi-bin/dispair.cgi?file=fiddle&view=%0A/usr/bin/id		

- 漏洞信息

59656
Dispair open() Function Arbitrary Remote Command Execution
Remote / Network Access Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

- 时间线

2002-07-30 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站