CVE-2002-1851
CVSS7.5
发布时间 :2002-12-31 00:00:00
修订时间 :2008-09-05 16:31:40
NMCO    

[原文]Buffer overflow in WS_FTP Pro 7.5 allows remote attackers to execute code on a client system via unknown attack vectors.


[CNNVD]Ipswitch WS_FTP Pro远程缓冲区溢出漏洞(CNNVD-200212-678)

        
        Ipswitch WS_FTP Pro是一款基于Microsoft Windows操作系统下的FTP客户端。
        Ipswitch WS_FTP Pro存在漏洞,可导致远程攻击者伪造服务器响应进行缓冲区溢出攻击。
        Ipswitch WS_FTP Pro对服务器提交的响应缺少正确的检查,可导致远程攻击者伪造服务器响应而导致拒绝服务攻击,精心构建发送响应数据可能使攻击者以WS_FTP Pro进程的权限在客户端系统上执行任意指令。
        在Ipswitch提供补丁之后,NGSSoftware将提供详细技术细节。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1851
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1851
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200212-678
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/4850
(UNKNOWN)  BID  4850
http://www.iss.net/security_center/static/10185.php
(UNKNOWN)  XF  wsftp-pro-client-bo(10185)

- 漏洞信息

Ipswitch WS_FTP Pro远程缓冲区溢出漏洞
高危 边界条件错误
2002-12-31 00:00:00 2005-10-20 00:00:00
远程  
        
        Ipswitch WS_FTP Pro是一款基于Microsoft Windows操作系统下的FTP客户端。
        Ipswitch WS_FTP Pro存在漏洞,可导致远程攻击者伪造服务器响应进行缓冲区溢出攻击。
        Ipswitch WS_FTP Pro对服务器提交的响应缺少正确的检查,可导致远程攻击者伪造服务器响应而导致拒绝服务攻击,精心构建发送响应数据可能使攻击者以WS_FTP Pro进程的权限在客户端系统上执行任意指令。
        在Ipswitch提供补丁之后,NGSSoftware将提供详细技术细节。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 不要用WS_FTP Pro访问不太可信的FTP站点。
        厂商补丁:
        Ipswitch
        --------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.ipswitch.com/

- 漏洞信息

59849
WS_FTP Pro Unspecified Remote Overflow
Remote / Network Access Input Manipulation
Loss of Integrity Solution Unknown
Exploit Unknown

- 漏洞描述

WS_FTP Pro is prone to an overflow condition. The program fails to properly sanitize user-supplied input resulting in an unspecified overflow. With a unspecified specially crafted content, a remote attacker can potentially cause unspecified impact.

- 时间线

2002-05-27 Unknow
Unknow Unknow

- 解决方案

OSVDB is not aware of a solution for this vulnerability.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站