CVE-2002-1838
CVSS5.0
发布时间 :2002-12-31 00:00:00
修订时间 :2008-09-05 16:31:38
NMCO    

[原文]Charities.cron 1.0.2 through 1.6.0 allows local users to write to arbitrary files via a symlink attack on temporary files.


[CNNVD]Charities.Cron以不安全方式创建临时文件漏洞(CNNVD-200212-309)

        
        Charities.cron是一款gawk脚本,每天由cron运行。
        Charities.cron在建立临时文件时不够安全,可导致本地攻击者进行符号链接攻击。
        Charities.cron在运行时会建立临时文件,但建立时没有对文件是否存在进行检查,而且建立的文件名称是可预测的,本地攻击者可以建立符号链接指向任意系统文件,造成文件被破坏,产生拒绝服务攻击,也存在权限提升攻击的可能。
        <**>

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:steve_sachs:charities.cron:1.6.0
cpe:/a:steve_sachs:charities.cron:1.5.0
cpe:/a:steve_sachs:charities.cron:1.0.2
cpe:/a:steve_sachs:charities.cron:1.1.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1838
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1838
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200212-309
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/4869
(PATCH)  BID  4869
http://www.stevesachs.com/charities.cron_CHANGELOG
(UNKNOWN)  CONFIRM  http://www.stevesachs.com/charities.cron_CHANGELOG

- 漏洞信息

Charities.Cron以不安全方式创建临时文件漏洞
中危 访问验证错误
2002-12-31 00:00:00 2005-10-20 00:00:00
本地  
        
        Charities.cron是一款gawk脚本,每天由cron运行。
        Charities.cron在建立临时文件时不够安全,可导致本地攻击者进行符号链接攻击。
        Charities.cron在运行时会建立临时文件,但建立时没有对文件是否存在进行检查,而且建立的文件名称是可预测的,本地攻击者可以建立符号链接指向任意系统文件,造成文件被破坏,产生拒绝服务攻击,也存在权限提升攻击的可能。
        <**>

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 暂时没有合适的临时解决方法。
        厂商补丁:
        Steve Sachs
        -----------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        Steve Sachs Upgrade Charities.cron 1.7.0
        
        http://www.stevesachs.com/index.cgi?go=/charities.cron

- 漏洞信息

59631
Charities.cron Temporary Files Symlink Arbitrary File Overwrite
Local Access Required Input Manipulation, Race Condition
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2002-05-23 Unknow
Unknow 2002-05-23

- 解决方案

Upgrade to version 1.7.0 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站