CVE-2002-1806
CVSS4.3
发布时间 :2002-12-31 00:00:00
修订时间 :2008-09-05 16:31:33
NMCOES    

[原文]Cross-site scripting (XSS) vulnerability in Drupal 4.0.0 allows remote attackers to inject arbitrary web script or HTML via Javascript in an IMG tag.


[CNNVD]Drupal新闻消息HTML注入漏洞(CNNVD-200212-094)

        Drupal 4.0.0版本存在跨站脚本(XSS)漏洞。远程攻击者借助IMG标签的Javascript注入任意web脚本或者HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1806
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1806
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200212-094
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/5801
(UNKNOWN)  BID  5801
http://www.iss.net/security_center/static/10173.php
(UNKNOWN)  XF  cms-news-image-xss(10173)
http://archives.neohapsis.com/archives/bugtraq/2002-09/0307.html
(VENDOR_ADVISORY)  BUGTRAQ  20020924 ECHU Alert #2: IMG Attack in the news : 6 CMS vulnerables

- 漏洞信息

Drupal新闻消息HTML注入漏洞
中危 跨站脚本
2002-12-31 00:00:00 2005-10-20 00:00:00
远程  
        Drupal 4.0.0版本存在跨站脚本(XSS)漏洞。远程攻击者借助IMG标签的Javascript注入任意web脚本或者HTML。

- 公告与补丁

        The vendor recommends updating to the latest release of Drupal.

- 漏洞信息 (21863)

Drupal 4.0 News Message HTML Injection Vulnerability (EDBID:21863)
php webapps
2002-09-25 Verified
0 das@hush.com
N/A [点击下载]
source: http://www.securityfocus.com/bid/5801/info

Problems with Drupal could allow an attacker to execute arbitrary script code in a vulnerable client.

Drupal fails to sufficiently filter potentially malicious HTML code from news posts. As a result, when a user views a news posting that contains malicious HTML code, the code contained in the posted message would be executed in their browser. This will occur in the context of the site running the Drupal software. 

<IMG SRC="javascript:alert('unsecure')"> 		

- 漏洞信息

59300
Drupal News Message Creation XSS
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Public Vendor Verified

- 漏洞描述

Drupal contains a flaw that allows a remote cross site scripting (XSS) attack. This flaw exists because the application does not validate the news message upon submission to the news creation script. This may allow a user to create a specially crafted URL that would execute arbitrary script code in a user's browser within the trust relationship between their browser and the server.

- 时间线

2002-09-24 Unknow
Unknow 2007-01-05

- 解决方案

Upgrade to version 4.6.11 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Drupal News Message HTML Injection Vulnerability
Input Validation Error 5801
Yes No
2002-09-25 12:00:00 2007-04-12 07:51:00
Discovery of this vulnerability credited to das@hush.com.

- 受影响的程序版本

Drupal Drupal 4.0 .0
Drupal Drupal 4.6.11

- 不受影响的程序版本

Drupal Drupal 4.6.11

- 漏洞讨论

Problems with Drupal could allow an attacker to execute arbitrary script code in a vulnerable client.

Drupal fails to sufficiently filter potentially malicious HTML code from news posts. As a result, when a user views a news posting that contains malicious HTML code, the code contained in the posted message would be executed in their browser. This will occur in the context of the site running the Drupal software.

- 漏洞利用

The following proof of concept was submitted.

<IMG SRC="javascript:alert('unsecure')">

- 解决方案

The vendor recommends updating to the latest release of Drupal.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站