CVE-2002-1788
CVSS7.5
发布时间 :2002-12-31 00:00:00
修订时间 :2008-09-05 16:31:31
NMCO    

[原文]Format string vulnerability in the nn_exitmsg function in nn 6.6.0 through 6.6.3 allows remote NNTP servers to execute arbitrary code via format strings in server responses.


[CNNVD]Kim Storm NN NNTP错误信息远程格式串溢出攻击漏洞(CNNVD-200212-097)

        
        Kim Storm nn是一款基于菜单的NNTP(NET信息传输协议)新闻阅读程序,可使用在多种Linux/Unix操作系统中。
        Kim Storm nn对服务器发送的100应答缺少正确处理,远程攻击者可以利用这个漏洞伪造服务器信息进行格式串溢出攻击。
        Kim Storm nn在系统上显示错误信息时,没有对错误信息进行正确的检查,攻击者可以伪造服务器提交包含恶意格式字符串的100应答给nn客户端,可导致泄露内存信息,或者写任意内存位置,可能以nn进程的权限在系统上执行任意指令。
        问题存在于nntp.c中的nn_exitmsg(1, line)函数:
        void nn_exitmsg(int n, char *fmt,...)
        {
         va_list ap;
         va_start(ap, fmt);
         vprintf(fmt, ap);
         putchar(NL);
         va_end(ap);
         nn_exit(n);
         /*NOTREACHED*/
        }
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:kim_storm:nn:6.6.3
cpe:/a:kim_storm:nn:6.6.1
cpe:/a:kim_storm:nn:6.6.0
cpe:/a:kim_storm:nn:6.6.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1788
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1788
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200212-097
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/5160
(PATCH)  BID  5160
http://www.iss.net/security_center/static/9491.php
(PATCH)  XF  nn-error-msg-format-string(9491)
http://www.osvdb.org/27086
(UNKNOWN)  OSVDB  27086

- 漏洞信息

Kim Storm NN NNTP错误信息远程格式串溢出攻击漏洞
高危 输入验证
2002-12-31 00:00:00 2005-10-20 00:00:00
远程  
        
        Kim Storm nn是一款基于菜单的NNTP(NET信息传输协议)新闻阅读程序,可使用在多种Linux/Unix操作系统中。
        Kim Storm nn对服务器发送的100应答缺少正确处理,远程攻击者可以利用这个漏洞伪造服务器信息进行格式串溢出攻击。
        Kim Storm nn在系统上显示错误信息时,没有对错误信息进行正确的检查,攻击者可以伪造服务器提交包含恶意格式字符串的100应答给nn客户端,可导致泄露内存信息,或者写任意内存位置,可能以nn进程的权限在系统上执行任意指令。
        问题存在于nntp.c中的nn_exitmsg(1, line)函数:
        void nn_exitmsg(int n, char *fmt,...)
        {
         va_list ap;
         va_start(ap, fmt);
         vprintf(fmt, ap);
         putchar(NL);
         va_end(ap);
         nn_exit(n);
         /*NOTREACHED*/
        }
        

- 公告与补丁

        厂商补丁:
        Kim Storm
        ---------
        升级程序:
        Kim Storm nn 6.6 .0:
        Kim Storm Upgrade nn-6.6.4.tar.Z
        ftp://ftp.nndev.org/pub/nn-6.6/nn-6.6.4.tar.Z
        Kim Storm nn 6.6.1:
        Kim Storm Upgrade nn-6.6.4.tar.Z
        ftp://ftp.nndev.org/pub/nn-6.6/nn-6.6.4.tar.Z
        Kim Storm nn 6.6.2:
        Kim Storm Upgrade nn-6.6.4.tar.Z
        ftp://ftp.nndev.org/pub/nn-6.6/nn-6.6.4.tar.Z
        Kim Storm nn 6.6.3:
        Kim Storm Upgrade nn-6.6.4.tar.Z
        ftp://ftp.nndev.org/pub/nn-6.6/nn-6.6.4.tar.Z

- 漏洞信息

27086
Multiple Vendor nn nn_exitmsg Function Remote Format String
Remote / Network Access, Local / Remote, Context Dependent Input Manipulation
Loss of Integrity

- 漏洞描述

A remote overflow exists in nm. The nm software fails to handle specific client error messages resulting in a format string vulnerability. With a specially crafted request, an attacker can cause the user to execute arbitrary commands on the system with the privileges of the nn process.

- 时间线

2002-07-04 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 6.6.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站