CVE-2002-1783
CVSS5.0
发布时间 :2002-12-31 00:00:00
修订时间 :2008-09-05 16:31:30
NMCO    

[原文]CRLF injection vulnerability in PHP 4.2.1 through 4.2.3, when allow_url_fopen is enabled, allows remote attackers to modify HTTP headers for outgoing requests by causing CRLF sequences to be injected into arguments that are passed to the (1) fopen or (2) file functions.


[CNNVD]PHP函数CRLF注入漏洞(CNNVD-200212-731)

        PHP从4.2.1到 4.2.3版本存在CRLF注入漏洞。当allow_url_fopen被启用时,远程攻击者可以通过导致CRLF序列注入被传递给(1) fopen 或 (2) file函数的参数中为离开的请求修改HTTP头。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:php:php:3.0.17PHP PHP 3.0.17
cpe:/a:php:php:4.1.1PHP PHP 4.1.1
cpe:/a:php:php:3.0.16PHP PHP 3.0.16
cpe:/a:php:php:4.0.5PHP PHP 4.0.5
cpe:/a:php:php:4.0.7PHP PHP 4.0.7
cpe:/a:php:php:4.0.4PHP PHP 4.0.4
cpe:/a:php:php:3.0.15PHP PHP 3.0.15
cpe:/a:php:php:4.2.0PHP PHP 4.2.0
cpe:/a:php:php:3.0.18PHP PHP 3.0.18
cpe:/a:php:php:4.2.2PHP PHP 4.2.2
cpe:/a:php:php:3.0.14PHP PHP 3.0.14
cpe:/a:php:php:4.1.0PHP PHP 4.1.0
cpe:/a:php:php:4.2.1PHP PHP 4.2.1
cpe:/a:php:php:4.0.3PHP PHP 4.0.3
cpe:/a:php:php:4.0.6PHP PHP 4.0.6
cpe:/a:php:php:4.1.2PHP PHP 4.1.2
cpe:/a:php:php:4.2.3PHP PHP 4.2.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1783
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1783
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200212-731
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/10080
(PATCH)  XF  php-fopen-crlf-injection(10080)
http://www.securityfocus.com/bid/5681
(PATCH)  BID  5681
http://www.debian.org/security/2002/dsa-168
(VENDOR_ADVISORY)  DEBIAN  DSA-168
http://archives.neohapsis.com/archives/bugtraq/2002-09/0132.html
(PATCH)  BUGTRAQ  20020912 Re: PHP fopen() CRLF Injection
http://archives.neohapsis.com/archives/bugtraq/2002-09/0086.html
(VENDOR_ADVISORY)  BUGTRAQ  20020909 PHP fopen() CRLF Injection

- 漏洞信息

PHP函数CRLF注入漏洞
中危 输入验证
2002-12-31 00:00:00 2005-10-20 00:00:00
远程  
        PHP从4.2.1到 4.2.3版本存在CRLF注入漏洞。当allow_url_fopen被启用时,远程攻击者可以通过导致CRLF序列注入被传递给(1) fopen 或 (2) file函数的参数中为离开的请求修改HTTP头。

- 公告与补丁

        The vendor has made a source code fix available via the CVS repository.
        Mandrake has released a new security advisory, (MDKSA-2003:082). Information on obtaining and applying fixes can be found in the referenced advisory.
        OpenPKG has released a new security advisory, OpenPKG-SA-2003.032. Information on obtaining and applying fixes can be found in the referenced advisory.
        Conectiva has released an advisory (CLA-2002:545) which contains fixes for this issue. Please see the attached advisory for further details on obtaining fixes.
        RedHat has released a security advisory, RHSA-2002:213-06. Information on obtaining and applying fixes can be found in the referenced advisory.
        HP has released an advisory for HP Secure OS, and has advised users to upgrade using the packages listed in Red Hat Security Advisory RHSA-2002:213-06.
        Fixes available:
        PHP PHP 3.0.18
        
        PHP PHP 4.0.3
        
        PHP PHP 4.0.4
        

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站