发布时间 :2002-12-31 00:00:00
修订时间 :2008-09-05 16:31:22

[原文]Multiple cross-site scripting (XSS) vulnerabilities in Actinic Catalog 4.7.0 allow remote attackers to inject arbitrary web script or HTML via (1) the query string argument to certain .pl files, (2) the REFPAGE parameter to, (3) PRODREF parameter to, or (4) hop parameter to

[CNNVD]Actinic Catalog跨站脚本漏洞(CNNVD-200212-120)

        Actinic Catalog 4.7.0版本存在多个跨站脚本(XSS)漏洞。远程攻击者借助(1)某些 .pl文件的查询字符串参数,(2)ca000007.pl的REFPAGE参数,(3)ss000007.pl的PRODREF参数,或者(4)ca000001.pl的hop参数注入任意web脚本或者HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  XF  actinic-html-tags-css(8180)
(UNKNOWN)  BID  4042
(UNKNOWN)  VIM  20060720 vendor ack/fix: Actinic Catalog Unspecified .pl Files XSS (fwd)

- 漏洞信息

Actinic Catalog跨站脚本漏洞
中危 跨站脚本
2002-12-31 00:00:00 2005-10-20 00:00:00
        Actinic Catalog 4.7.0版本存在多个跨站脚本(XSS)漏洞。远程攻击者借助(1)某些 .pl文件的查询字符串参数,(2)ca000007.pl的REFPAGE参数,(3)ss000007.pl的PRODREF参数,或者(4)ca000001.pl的hop参数注入任意web脚本或者HTML。

- 公告与补丁

        The vendor has released version 7.0.6 to address this issue; please contact the vendor for updates.

- 漏洞信息

Actinic Catalog Unspecified .pl Files XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Actinic Catalog contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate unspecified variable(s) upon submission to unspecified Perl script(s). This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2006-07-13 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 6.1.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者