CVE-2002-1724
CVSS6.8
发布时间 :2002-12-31 00:00:00
修订时间 :2008-09-05 16:31:21
NMCO    

[原文]Cross-site scripting vulnerability (XSS) in phpimageview.php for PHPImageView 1.0 allows remote attackers to execute arbitrary script as other users via the pic parameter.


[CNNVD]PHPImageView跨站脚本执行漏洞(CNNVD-200212-507)

        
        PHPImageView是一款简单的图象显示程序。
        PHPImageView对用户提交的URL请求数据缺少正确充分的检查,可导致远程攻击者进行跨站脚本执行攻击。
        当返回包含用户输入的错误信息时,PHPImageView没有过滤脚本代码和HTML标记,可导致攻击者提供包含恶意脚本代码的信息给PHPImageView,当PHPImageView生成的错误信息由其他用户浏览时,可导致恶意代码在浏览用户的浏览器上被执行,使用户基于Cookie认证的信息被泄露。
        另外,存在漏洞可以调用phpinfo()函数,导致攻击者获得操作系统设置信息,包括文件结构和版本信息。
        

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1724
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1724
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200212-507
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/9000
(PATCH)  XF  phpimageview-var-css(9000)
http://www.securityfocus.com/bid/4668
(UNKNOWN)  BID  4668
http://www.ifrance.com/kitetoua/tuto/5holes4.txt
(VENDOR_ADVISORY)  MISC  http://www.ifrance.com/kitetoua/tuto/5holes4.txt

- 漏洞信息

PHPImageView跨站脚本执行漏洞
中危 设计错误
2002-12-31 00:00:00 2005-10-20 00:00:00
远程  
        
        PHPImageView是一款简单的图象显示程序。
        PHPImageView对用户提交的URL请求数据缺少正确充分的检查,可导致远程攻击者进行跨站脚本执行攻击。
        当返回包含用户输入的错误信息时,PHPImageView没有过滤脚本代码和HTML标记,可导致攻击者提供包含恶意脚本代码的信息给PHPImageView,当PHPImageView生成的错误信息由其他用户浏览时,可导致恶意代码在浏览用户的浏览器上被执行,使用户基于Cookie认证的信息被泄露。
        另外,存在漏洞可以调用phpinfo()函数,导致攻击者获得操作系统设置信息,包括文件结构和版本信息。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 修改程序,严格过滤用户输入的数据,不允许有javascript脚本或对<>符号进行转换。
        厂商补丁:
        onlinetools.org
        ---------------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.onlinetools.org/phpimageview/

- 漏洞信息

27071
PHPImageView phpimageview.php pic Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2002-05-04 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.0 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站