CVE-2002-1661
CVSS5.0
发布时间 :2002-12-31 00:00:00
修订时间 :2016-10-17 22:27:25
NMCOS    

[原文]The leafnode server in leafnode 1.9.20 to 1.9.29 allows remote attackers to cause a denial of service (infinite loop) when leafnode requests a cross-posted article to one group whose name is a prefix of another group.


[CNNVD]Leafnode资源耗竭远程拒绝服务攻击漏洞(CNNVD-200212-348)

        
        leafnode是一款Usnet新闻的存储转发代理,使用网络新闻传输协议。
        leafnode在处理特殊新闻张贴时存在问题,远程攻击者可以利用这个漏洞使leafnode消耗所有CPU资源而导致拒绝服务。
        攻击者可以通过交叉地把新闻张贴到多个新闻组中,而某几个新闻组的前缀是其他新闻组名,可导致leafnode在通过message-id来获得新闻文章时,进入无限循环,消耗所有CPU资源,使服务程序停止对正常服务的响应。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:leafnode:leafnode:1.9.27
cpe:/a:leafnode:leafnode:1.9.26
cpe:/a:leafnode:leafnode:1.9.25
cpe:/a:leafnode:leafnode:1.9.24
cpe:/a:leafnode:leafnode:1.9.19
cpe:/a:leafnode:leafnode:1.9.29
cpe:/a:leafnode:leafnode:1.9.23
cpe:/a:leafnode:leafnode:1.9.22
cpe:/a:leafnode:leafnode:1.9.21
cpe:/a:leafnode:leafnode:1.9.20

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1661
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1661
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200212-348
(官方数据源) CNNVD

- 其它链接及资源

http://leafnode.sourceforge.net/leafnode-SA-2002-01.txt
(PATCH)  CONFIRM  http://leafnode.sourceforge.net/leafnode-SA-2002-01.txt
http://marc.info/?l=bugtraq&m=104127108823436&w=2
(UNKNOWN)  BUGTRAQ  20021229 Leafnode security announcement SA:2002:01
http://marc.info/?l=bugtraq&m=104152295210075&w=2
(UNKNOWN)  BUGTRAQ  20030102 GLSA: leafnode
http://www.mandriva.com/security/advisories?name=MDKSA-2003:005
(UNKNOWN)  MANDRAKE  MDKSA-2003:005
http://www.securityfocus.com/bid/6490
(PATCH)  BID  6490
http://www.securitytracker.com/id?1005865
(UNKNOWN)  SECTRACK  1005865
http://xforce.iss.net/xforce/xfdb/10942
(UNKNOWN)  XF  leafnode-nntp-dos(10942)

- 漏洞信息

Leafnode资源耗竭远程拒绝服务攻击漏洞
中危 其他
2002-12-31 00:00:00 2005-10-20 00:00:00
远程  
        
        leafnode是一款Usnet新闻的存储转发代理,使用网络新闻传输协议。
        leafnode在处理特殊新闻张贴时存在问题,远程攻击者可以利用这个漏洞使leafnode消耗所有CPU资源而导致拒绝服务。
        攻击者可以通过交叉地把新闻张贴到多个新闻组中,而某几个新闻组的前缀是其他新闻组名,可导致leafnode在通过message-id来获得新闻文章时,进入无限循环,消耗所有CPU资源,使服务程序停止对正常服务的响应。
        

- 公告与补丁

        厂商补丁:
        Leafnode
        --------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        Leafnode Upgrade leafnode-1.9.31.rel.tar.bz2
        
        http://prdownloads.sourceforge.net/leafnode/leafnode-1.9.31.rel.tar.bz2?download

- 漏洞信息

16568
leafnode Cross-Posted Article Group Name Prefix DoS
Denial of Service
Loss of Availability Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2002-12-29 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.9.30 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Leafnode Resource Exhaustion Denial Of Service Vulnerability
Failure to Handle Exceptional Conditions 6490
Yes No
2002-12-30 12:00:00 2009-07-11 07:17:00
This vulnerability was reported in the product changelog.

- 受影响的程序版本

Leafnode Leafnode 1.9.29
Leafnode Leafnode 1.9.27
Leafnode Leafnode 1.9.26
Leafnode Leafnode 1.9.25
Leafnode Leafnode 1.9.24
+ Mandriva Linux Mandrake 9.0
Leafnode Leafnode 1.9.23
Leafnode Leafnode 1.9.22
Leafnode Leafnode 1.9.21
Leafnode Leafnode 1.9.20
Leafnode Leafnode 1.9.19
+ Mandriva Linux Mandrake 8.2 ppc
+ Mandriva Linux Mandrake 8.2
Leafnode Leafnode 1.9.31
Leafnode Leafnode 1.9.30

- 不受影响的程序版本

Leafnode Leafnode 1.9.31
Leafnode Leafnode 1.9.30

- 漏洞讨论

A denial of service vulnerability has been reported for Leafnode. The vulnerability occurs when Leafnode tries to retrieve certain news postings.

An attacker can exploit this vulnerability by cross-posting to several newsgroups where some groups are prefixes of others. When leafnode attempts to retrieve these news articles by the message-id, it will go into an infinite loop and consume all CPU resources thereby leading to a denial of service condition.

- 漏洞利用

There is no exploit code required.

- 解决方案

Gentoo Linux has released an advisory. Users who have installed new-news/leafnode-1.9.24 or earlier are advised to update their systems by issuing the following commands:

emerge rsync
emerge leafnode
emerge clean

This vulnerability does not affect Leafnode 1.9.30 and 1.9.31. Users are advised to install the latest version:


Leafnode Leafnode 1.9.19

Leafnode Leafnode 1.9.20

Leafnode Leafnode 1.9.21

Leafnode Leafnode 1.9.22

Leafnode Leafnode 1.9.23

Leafnode Leafnode 1.9.24

Leafnode Leafnode 1.9.25

Leafnode Leafnode 1.9.26

Leafnode Leafnode 1.9.27

Leafnode Leafnode 1.9.29

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站