CVE-2002-1660
CVSS7.5
发布时间 :2002-12-31 00:00:00
修订时间 :2008-09-05 16:31:11
NMCOE    

[原文]calendar.php in vBulletin before 2.2.0 allows remote attackers to execute arbitrary commands via shell metacharacters in the command parameter.


[CNNVD]vBulletin Calendar远程执行任意命令漏洞(CNNVD-200212-127)

        
        vBulletin Calendar是一款基于WEB的日历程序。
        vBulletin Calendar对用户输入缺少正确过滤,远程攻击者可以利用这个漏洞以WEB权限在系统上执行任意命令。
        vBulletin Calendar中的calendar.php脚本对用户提交给comma参数的值缺少过滤,攻击者提交特殊字符并追加任意系统命令,可能以WEB进程的权限(一般是nobody)在系统上执行任意命令。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-78 [OS命令中使用的特殊元素转义处理不恰当(OS命令注入)]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1660
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1660
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200212-127
(官方数据源) CNNVD

- 其它链接及资源

http://securitytracker.com/id?1005284
(PATCH)  SECTRACK  1005284
http://xforce.iss.net/xforce/xfdb/10176
(VENDOR_ADVISORY)  XF  vbulletin-calendar-command-execution(10176)
http://www.securityfocus.com/bid/5820
(UNKNOWN)  BID  5820
http://www.securiteam.com/exploits/5QP0P158AC.html
(UNKNOWN)  MISC  http://www.securiteam.com/exploits/5QP0P158AC.html

- 漏洞信息

vBulletin Calendar远程执行任意命令漏洞
高危 输入验证
2002-12-31 00:00:00 2005-10-20 00:00:00
远程  
        
        vBulletin Calendar是一款基于WEB的日历程序。
        vBulletin Calendar对用户输入缺少正确过滤,远程攻击者可以利用这个漏洞以WEB权限在系统上执行任意命令。
        vBulletin Calendar中的calendar.php脚本对用户提交给comma参数的值缺少过滤,攻击者提交特殊字符并追加任意系统命令,可能以WEB进程的权限(一般是nobody)在系统上执行任意命令。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 在漏洞修补之前,暂时停止calendar.php程序的使用。
        厂商补丁:
        VBulletin
        ---------
        目前厂商已经发布了升级补丁以修复这个安全问题,请升级vBulletin到2.2.8版本:
        
        http://www.vbulletin.com/

- 漏洞信息 (21874)

VBulletin 2.0.3 Calendar.PHP Command Execution Vulnerability (EDBID:21874)
php webapps
2002-09-27 Verified
0 gosper
N/A [点击下载]
source: http://www.securityfocus.com/bid/5820/info

A remote command execution vulnerability has been reported for vBulletin. The vulnerability is due to vBulletin failing to properly sanitize user-supplied input from URI parameters. 

An attacker can exploit this vulnerability to execute malicious commands on the vulnerable system.

http://www.example.com/calendar.php?calbirthdays=1&action=getday&day=2001-8-15&comma=%22;echo%20'';%20echo%20%60<command>%20%60;die();echo%22

where <command> signifies a command to be executed on the system.		

- 漏洞信息

3299
vBulletin calendar.php comma Parameter Arbitrary Command Execution
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

vBulletin contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to the 'calendar.php' script not properly sanitizing user input supplied to the 'comma' variable. By sending a specially crafted request containing shell metacharacters, a remote attacker could execute arbitrary commands resulting in a loss of integrity.

- 时间线

2002-09-24 Unknow
2002-09-24 Unknow

- 解决方案

Upgrade to version 2.2.0 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站