CVE-2002-1646
CVSS7.5
发布时间 :2002-12-31 00:00:00
修订时间 :2008-09-05 16:31:09
NMCOS    

[原文]SSH Secure Shell for Servers 3.0.0 to 3.1.1 allows remote attackers to override the AllowedAuthentications configuration and use less secure authentication schemes (e.g. password) than configured for the server.


[CNNVD]SSH Communications SSH AllowedAuthentications配置存在漏洞(CNNVD-200212-240)

        
        Secure Shell是一款由SSH Communications分发和维护的商业SSH实现。
        Secure Shell中在处理配置文件中的"AllowedAuthentications"选项存在漏洞,可导致远程攻击者绕过其它强壮的认证机制。
        在SSH Secure Shell for Servers中配置文件中选项"AllowedAuthentications" 用来设置验证模式,如果"Password"关键词不包含在此选项中,就不能使用密码进行验证访问。但存在漏洞,可以导致某些基于secure shell协议2的客户端绕过此配置选项设置,仍旧使用密码方式进行验证。
        这可导致攻击者绕过一些如SecurID或者数字证书方式的验证。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:ssh:secure_shell_for_servers:3.0.1SSH Communications Security SSH Secure Shell for Servers 3.0.1
cpe:/a:ssh:secure_shell_for_servers:3.1.1SSH Communications Security SSH Secure Shell for Servers 3.1.1
cpe:/a:ssh:secure_shell_for_servers:3.0SSH Communications Security SSH Secure Shell for Servers 3.0
cpe:/a:ssh:secure_shell_for_servers:3.1SSH Communications Security SSH Secure Shell for Servers 3.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1646
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1646
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200212-240
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/341187
(UNKNOWN)  CERT-VN  VU#341187
http://xforce.iss.net/xforce/xfdb/9163
(PATCH)  XF  ssh-allowedauthentications-bypass-auth(9163)
http://www.ssh.com/products/ssh/advisories/authentication.cfm
(PATCH)  CONFIRM  http://www.ssh.com/products/ssh/advisories/authentication.cfm
http://www.securityfocus.com/bid/4810
(PATCH)  BID  4810
http://archives.neohapsis.com/archives/bugtraq/2002-05/0204.html
(PATCH)  BUGTRAQ  20020523 [Fwd: Updated version of SSH Secure Shell available]
http://www.ciac.org/ciac/bulletins/m-081.shtml
(UNKNOWN)  CIAC  M-081
http://www.ssh.com/company/newsroom/article/201/
(UNKNOWN)  CONFIRM  http://www.ssh.com/company/newsroom/article/201/

- 漏洞信息

SSH Communications SSH AllowedAuthentications配置存在漏洞
高危 设计错误
2002-12-31 00:00:00 2005-10-20 00:00:00
远程  
        
        Secure Shell是一款由SSH Communications分发和维护的商业SSH实现。
        Secure Shell中在处理配置文件中的"AllowedAuthentications"选项存在漏洞,可导致远程攻击者绕过其它强壮的认证机制。
        在SSH Secure Shell for Servers中配置文件中选项"AllowedAuthentications" 用来设置验证模式,如果"Password"关键词不包含在此选项中,就不能使用密码进行验证访问。但存在漏洞,可以导致某些基于secure shell协议2的客户端绕过此配置选项设置,仍旧使用密码方式进行验证。
        这可导致攻击者绕过一些如SecurID或者数字证书方式的验证。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 在sshd2_config配置文件中使用"RequiredAuthentications"来代替"AllowedAuthentications"关键词:
        RequiredAuthentications
        hostbased, publickey
        厂商补丁:
        SSH Communications Security
        ---------------------------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        SSH Communications Security Upgrade ssh-3.1.2.tar.gz
        ftp://ftp.ssh.com/pub/ssh/ssh-3.1.2.tar.gz

- 漏洞信息

18238
SSH Secure Shell for Servers AllowedAuthentications Remote Bypass
Remote / Network Access Input Manipulation
Loss of Confidentiality, Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2002-05-23 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 3.1.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

SSH Communications Secure Shell Server AllowedAuthentications Configuration Overriding Vulnerability
Design Error 4810
Yes No
2002-05-23 12:00:00 2009-07-11 12:46:00
Vulnerability announced by SSH Communications Security.

- 受影响的程序版本

SSH Communications Security SSH2 for Win32 3.1.1
SSH Communications Security SSH2 for Win32 3.1
SSH Communications Security SSH2 for Unix 3.1.1
SSH Communications Security SSH2 for Unix 3.1
SSH Communications Security SSH2 3.0.1
SSH Communications Security SSH2 3.0
SSH Communications Security SSH2 for Win32 3.1.2
SSH Communications Security SSH2 for Unix 3.1.2

- 不受影响的程序版本

SSH Communications Security SSH2 for Win32 3.1.2
SSH Communications Security SSH2 for Unix 3.1.2

- 漏洞讨论

Secure Shell is the commercial SSH implementation distributed and maintained by SSH Communications. It is available for the Unix, Linux, and Microsoft Windows platforms.

Under some circumstances, it may be possible for a remote user to bypass the "AllowedAuthentications" specified in the server configuration. This could allow a user to authenticate using a different or weaker means, such as a password. In such a situation where stronger authentication protocols are in place, and system user accounts have been secured with weak passwords, an attacker may be able to gain access to the system using the weak password, rather than the strong authentcation scheme.

- 漏洞利用

Currently the SecurityFocus staff are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Vendor fixes available.


SSH Communications Security SSH2 3.0

SSH Communications Security SSH2 3.0.1

SSH Communications Security SSH2 for Unix 3.1

SSH Communications Security SSH2 for Win32 3.1
  • SSH Communications Security ssh 3.1.2 for Win32
    Contact SSH Communication Security for details on obtaining this fix.


SSH Communications Security SSH2 for Win32 3.1.1
  • SSH Communications Security ssh 3.1.2 for Win32
    Contact SSH Communication Security for details on obtaining this fix.


SSH Communications Security SSH2 for Unix 3.1.1

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站