CVE-2002-1645
CVSS10.0
发布时间 :2002-11-25 00:00:00
修订时间 :2008-09-05 16:31:09
NMCO    

[原文]Buffer overflow in the URL catcher feature for SSH Secure Shell for Workstations client 3.1 to 3.2.0 allows remote attackers to execute arbitrary code via a long URL.


[CNNVD]SSH Communications Secure Shell Windows客户端URLCatcher缓冲区溢出漏洞(CNNVD-200211-039)

        Workstations客户端3.1至3.2.0版本中SSH Secure Shell的URL catcher功能存在缓冲区溢出漏洞。远程攻击者可以借助超长URL执行任意代码。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:ssh:ssh2:3.1
cpe:/a:ssh:ssh2:3.2
cpe:/a:ssh:ssh2:3.1.4
cpe:/a:ssh:ssh2:3.1.2
cpe:/a:ssh:ssh2:3.1.3
cpe:/a:ssh:ssh2:3.1.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1645
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1645
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200211-039
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/140977
(PATCH)  CERT-VN  VU#140977
http://www.ssh.com/company/newsroom/article/287/
(PATCH)  CONFIRM  http://www.ssh.com/company/newsroom/article/287/
http://www.securityfocus.com/bid/6263
(PATCH)  BID  6263
http://xforce.iss.net/xforce/xfdb/10723
(VENDOR_ADVISORY)  XF  ssh-client-url-bo(10723)

- 漏洞信息

SSH Communications Secure Shell Windows客户端URLCatcher缓冲区溢出漏洞
危急 缓冲区溢出
2002-11-25 00:00:00 2005-10-20 00:00:00
远程  
        Workstations客户端3.1至3.2.0版本中SSH Secure Shell的URL catcher功能存在缓冲区溢出漏洞。远程攻击者可以借助超长URL执行任意代码。

- 公告与补丁

        Fixes available:
        SSH Communications Security SSH2 3.1
        
        SSH Communications Security SSH2 3.1.1
        
        SSH Communications Security SSH2 3.1.2
        
        SSH Communications Security SSH2 3.1.3
        
        SSH Communications Security SSH2 3.1.4
        
        SSH Communications Security SSH2 3.2
        

- 漏洞信息

18239
SSH Secure Shell for Workstations URL Catcher Feature Remote Overflow
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

A remote overflow exists in SSH Secure Shell for Workstations. The URL Catcher feature fails to check the length of clicked URLs in terminal windows, resulting in a buffer overflow. With a specially crafted request, an attacker can cause execution of arbitrary code resulting in a loss of integrity.

- 时间线

2002-11-25 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 3.1.5 or higher, or 3.2.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站