CVE-2002-1627
CVSS5.0
发布时间 :2002-12-31 00:00:00
修订时间 :2008-09-05 16:31:06
NMCOS    

[原文]Directory traversal vulnerability in quiz.cgi for Mike Spice Quiz Me! before 0.6 allows remote attackers to write arbitrary files via .. (dot dot) sequences in the quiz parameter.


[CNNVD]Mike Spice Quiz Me! 输入确认漏洞(CNNVD-200212-562)

        Mike Spice Quiz Me! 0.6之前版本的quiz.cgi存在目录遍历漏洞。远程攻击者可以借助quiz参数的..(点 点)序列写入任意文件。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1627
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1627
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200212-562
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/318835
(PATCH)  CERT-VN  VU#318835
http://xforce.iss.net/xforce/xfdb/7970
(PATCH)  XF  quizme-gain-privileges(7970)
http://www.securityfocus.com/bid/3857
(PATCH)  BID  3857
http://securitytracker.com/id?1003254
(UNKNOWN)  SECTRACK  1003254

- 漏洞信息

Mike Spice Quiz Me! 输入确认漏洞
中危 路径遍历
2002-12-31 00:00:00 2005-10-20 00:00:00
远程  
        Mike Spice Quiz Me! 0.6之前版本的quiz.cgi存在目录遍历漏洞。远程攻击者可以借助quiz参数的..(点 点)序列写入任意文件。

- 公告与补丁

        Reportedly Quiz Me! version 0.6 is not vulnerable to this issue.
        Mike Spice Quiz Me! 0.5
        

- 漏洞信息

3515
Mike's Quiz Me quiz.cgi quiz Parameter Traversal Arbitrary Command Execution

- 漏洞描述

Mike Spice's Quiz Me! contains a flaw that allows a remote attacker to overwrite arbitrary files. The issue is due to the quiz.cgi script not sanitizing input supplied to the "quiz" variable. If an attacker supplies a traversal style attack (../../), they can supply an alternate file to be written to as long as the web server has write privileges to the desired file.

- 时间线

2002-01-10 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.6 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Mike Spice Quiz Me! Input Validation Vulnerability
Input Validation Error 3857
Yes No
2002-01-10 12:00:00 2009-07-11 09:56:00
Published in the Quiz Me! changelog on January 10, 2002.

- 受影响的程序版本

Mike Spice Quiz Me! 0.5
Mike Spice Quiz Me! 0.6

- 不受影响的程序版本

Mike Spice Quiz Me! 0.6

- 漏洞讨论

Quiz Me! is an application enabling users to design quizzes over the web. Quiz Me! is maintained by Mike Spice.

It may be possible in possible to overwrite system files that are webserver writeable with custom data.

This is due to an input validation vulnerability in 'quiz.cgi' when the 'quiz' CGI variable is passed to the perl open() function. Attackers can use directory traversal '../' character sequences and NULL bytes to specify any file and path on the filesystem.

- 漏洞利用

This vulnerability can be exploited with a web browser.

- 解决方案

Reportedly Quiz Me! version 0.6 is not vulnerable to this issue.


Mike Spice Quiz Me! 0.5

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站