发布时间 :2002-08-30 00:00:00
修订时间 :2011-03-07 21:10:31

[原文]Multiple buffer overflows in HP Tru64 UNIX 5.1a, 5.1, 5.0a, 4.0g, and 4.0f allow local users to gain privileges via (1) lpc, (2) lpd, (3) lpq, (4) lpr, or (5) lprm.

[CNNVD]Tru64 chsh本地权限提升漏洞(CNNVD-200208-253)

        部分HP Tru64操作系统的chsh工具存在问题,允许非特权用户获得root用户权限。

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:hp:tru64:5.1HP Compaq Tru64 5.1
cpe:/o:hp:tru64:4.0gHP Tru64 4.0g
cpe:/o:hp:hp-ux:11.22HP-UX 11i v1.6
cpe:/o:hp:hp-ux:11.04HP HP-UX 11.04
cpe:/o:hp:tru64:4.0fHP Tru64 4.0f
cpe:/o:hp:hp-ux:11.00HP-UX 11.00
cpe:/o:hp:tru64:5.0aHP Tru64 5.0a
cpe:/o:hp:tru64:5.1aHP Tru64 5.1a
cpe:/o:hp:hp-ux:10.20HP HP-UX 10.20
cpe:/o:hp:hp-ux:11.11HP-UX 11.11

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  XF  tru64-multiple-binaries-bo(10016)

- 漏洞信息

Tru64 chsh本地权限提升漏洞
中危 边界条件错误
2002-08-30 00:00:00 2005-10-20 00:00:00
        部分HP Tru64操作系统的chsh工具存在问题,允许非特权用户获得root用户权限。

- 公告与补丁

        * 暂时没有合适的临时解决方法。
        SSRT2257:HP Tru64 UNIX /usr/bin/su buffer overflow potential exploit

        Compaq Tru64 4.0 g:
        Compaq Patch t64v40gb17-c0010404-14948-es-20020730.tar

        Compaq Tru64 4.0 f:
        Compaq Patch duv40fb18-c0067403-14947-es-20020730.tar

        Compaq Tru64 5.0 a:
        Compaq Patch t64v50ab17-c0018404-14949-es-20020730.tar

        Compaq Tru64 5.1 a:
        Compaq Patch t64v51ab2-c0041400-14950-es-20020730.tar

        Compaq Tru64 5.1:
        Compaq Patch t64v51b19-c0136900-14951-es-20020730.tar

- 漏洞信息

HP Tru64 UNIX lpc Unspecified Local Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2002-09-05 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

HP Tru64 UNIX Multiple Local and Remote Buffer Overflow Vulnerabilities
Boundary Condition Error 5599
Yes Yes
2002-08-30 12:00:00 2009-07-11 03:56:00
These issues were initially published in a HP Security Bulletin. Discovery of the majority of the issues reported in the advisory is credited to Snosoft.

- 受影响的程序版本

Compaq Tru64 5.1 a PK2 (BL2)
Compaq Tru64 5.1 a PK1 (BL1)
Compaq Tru64 5.1 a
Compaq Tru64 5.1 PK5 (BL19)
Compaq Tru64 5.1 PK4 (BL18)
Compaq Tru64 5.1 PK3 (BL17)
Compaq Tru64 5.1
Compaq Tru64 5.0 a PK3 (BL17)
Compaq Tru64 5.0 a
Compaq Tru64 5.0 PK4 (BL18)
Compaq Tru64 5.0 PK4 (BL17)
Compaq Tru64 5.0
Compaq Tru64 4.0 g PK3 (BL17)
Compaq Tru64 4.0 g
Compaq Tru64 4.0 f PK7 (BL18)
Compaq Tru64 4.0 f PK6 (BL17)
Compaq Tru64 4.0 f
Compaq Digital Unix 4.0 f

- 漏洞讨论

HP has reported multiple local and remote buffer overflow vulnerabilities in various binaries that ship with Tru64 UNIX. HP has also announced an undisclosed denial of service issue in /usr/sbin/ping, which is covered in the advisory and addressed in the included fixes.

A number of these utilities may potentially be exploited by an attacker to execute code with elevated privileges or to cause a denial of service condition. In the instance of the local buffer overflows, exploitation of some of these binaries may not yield any extra privileges for the attacker, if they are not installed setuid/setgid. With remote buffer overflows, successful exploitation may allow an attacker to execute arbitrary code with the privileges of the user running the utility or server.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: <>.

- 解决方案

HP has released fixes for Tru64 UNIX/TruCluster systems. Note that appropriate patchkits must be applied.

Compaq Tru64 4.0 g PK3 (BL17)

Compaq Tru64 4.0 f PK7 (BL18)

Compaq Tru64 5.0 a PK3 (BL17)

Compaq Tru64 5.1 a PK2 (BL2)

Compaq Tru64 5.1 PK5 (BL19)

- 相关参考