CVE-2002-1587
CVSS2.1
发布时间 :2002-12-04 00:00:00
修订时间 :2008-09-10 15:15:00
NMCO    

[原文]The libthread library (libthread.so.1) for Solaris 2.5.1 through 8 allows local users to cause a denial of service (hang) of an application that uses libthread by causing the application to wait for a certain mutex.


[CNNVD]Sun Solaris Libthread库本地拒绝服务攻击漏洞(CNNVD-200212-002)

        Solaris是一款由Sun microsystems公司开发和维护的商业性质UNIX操作系统。
        当应用程序连接到libthread库时存在问题,本地攻击者可以利用这个漏洞使应用程序终止,产生拒绝服务。应用程序连接到32-bit libthread (/usr/lib/libthread.so.1)或64-bit libthread (/usr/lib/sparcv9/libthread.so.1)库可能导致挂起,一旦出现这个情况,应用程序可被终止和重新启动。

- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:sun:solaris:8.0
cpe:/o:sun:solaris:2.6
cpe:/o:sun:solaris:7.0::x86
cpe:/o:sun:solaris:7.0
cpe:/o:sun:solaris:8.0::x86
cpe:/o:sun:solaris:2.6::x86
cpe:/o:sun:solaris:2.5.1::x86
cpe:/o:sun:solaris:2.5.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1587
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1587
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200212-002
(官方数据源) CNNVD

- 其它链接及资源

http://sunsolve.sun.com/search/document.do?assetkey=1-26-46867-1
(PATCH)  SUNALERT  46867
http://xforce.iss.net/xforce/xfdb/11146
(UNKNOWN)  XF  solaris-libthread-dos(11146)
http://www.securityfocus.com/bid/6318
(UNKNOWN)  BID  6318

- 漏洞信息

Sun Solaris Libthread库本地拒绝服务攻击漏洞
低危
2002-12-04 00:00:00 2012-11-30 00:00:00
本地  
        Solaris是一款由Sun microsystems公司开发和维护的商业性质UNIX操作系统。
        当应用程序连接到libthread库时存在问题,本地攻击者可以利用这个漏洞使应用程序终止,产生拒绝服务。应用程序连接到32-bit libthread (/usr/lib/libthread.so.1)或64-bit libthread (/usr/lib/sparcv9/libthread.so.1)库可能导致挂起,一旦出现这个情况,应用程序可被终止和重新启动。

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 在运行应用程序时设置如下环境变量:
         LD_BIND_NOW=1
        这会迫使进入'non-lazy'实时绑定,LD_BIND_NOW在进程初始化阶段,在传输控制给应用程序之前,会导致实时连接库重新布置数据引用和函数引用。
        或者在Solaris 8中,使用可替换(alternate)libthread库,如果使用可替换libthread库,应用程序不需要重新连接或者在使用可变库之前重新编译。在启动任何多线程应用程序之前设置LD_LIBRARY_PATH。
        64-bit应用程序使用ksh如下所示:
         $ export LD_LIBRARY_PATH_64=/usr/lib/lwp/sparcv9:$LD_LIBRARY_PATH_64
        
        32-bit应用程序使用ksh如下所示:
         $ export LD_LIBRARY_PATH=/usr/lib/lwp:$LD_LIBRARY_PATH
        厂商补丁:
        Sun
        ---
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        solaris 9系统不受此漏洞影响。
        补丁下载:
        Sun Solaris 2.5.1 _x86:
        Sun Solaris 2.5.1:
        Sun Solaris 2.6 _x86:
        Sun Solaris 2.6:
        Sun Solaris 7.0 _x86:
        Sun Solaris 7.0:
        Sun Solaris 8.0 _x86:
        Sun Patch 108828-32
        
        http://sunsolve.sun.com/pub-cgi/findPatch.pl?patchId=108828&rev=32

        Sun Solaris 8.0:
        Sun Patch 108827-32
        
        http://sunsolve.sun.com/pub-cgi/findPatch.pl?patchId=108827&rev=32

- 漏洞信息

14872
Solaris libthread.so.1 Library Local DoS
Denial of Service
Loss of Availability

- 漏洞描述

Unknown or Incomplete

- 时间线

2002-09-02 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站