CVE-2002-1562
CVSS5.0
发布时间 :2003-05-12 00:00:00
修订时间 :2016-12-07 21:59:22
NMCOS    

[原文]Directory traversal vulnerability in thttpd, when using virtual hosting, allows remote attackers to read arbitrary files via .. (dot dot) sequences in the Host: header.


[CNNVD]Acme thttpd/mini_httpd虚拟主机文件泄漏漏洞(CNNVD-200305-039)

        thttpd存在目录遍历漏洞。当使用虚拟主机时远程攻击者可以借助Host: header的..(点 点)读取任意文件。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1562
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1562
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200305-039
(官方数据源) CNNVD

- 其它链接及资源

http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000777
(UNKNOWN)  CONECTIVA  CLA-2003:777
http://marc.info/?l=thttpd&m=103609565110472&w=2
(UNKNOWN)  CONFIRM  http://marc.info/?l=thttpd&m=103609565110472&w=2
http://news.php.net/article.php?group=php.cvs&article=15698
(UNKNOWN)  CONFIRM  http://news.php.net/article.php?group=php.cvs&article=15698
https://www.debian.org/security/2003/dsa-396
(UNKNOWN)  DEBIAN  DSA-396

- 漏洞信息

Acme thttpd/mini_httpd虚拟主机文件泄漏漏洞
中危 路径遍历
2003-05-12 00:00:00 2006-08-03 00:00:00
远程  
        thttpd存在目录遍历漏洞。当使用虚拟主机时远程攻击者可以借助Host: header的..(点 点)读取任意文件。

- 公告与补丁

        SuSE has released an advisory (SuSE-SA:2003:044) to address this issue in SuSE Linux platforms. Affected users are advised to apply fixes as soon as possible. Further information regarding obtaining and applying these fixes can be found in the referenced advisory.
        Debian has released an advisory (DSA 396-1) and fixes to address this issue in thttpd.
        Conectiva has released a security advisory (CLA-2003:777) which contains fixes to address this issue. Users are advised to upgrade as soon as possible.
        This issue has been addressed in thttpd 2.24 and mini_httpd 1.18.
        Acme mini_httpd 1.0 0
        
        Acme mini_httpd 1.0 1
        
        Acme thttpd 1.0
        
        Acme mini_httpd 1.10 0
        
        Acme mini_httpd 1.11
        
        Acme mini_httpd 1.12
        
        Acme mini_httpd 1.13
        
        Acme mini_httpd 1.14
        
        Acme mini_httpd 1.15 b
        
        Acme mini_httpd 1.15 c
        
        Acme mini_httpd 1.15
        
        Acme mini_httpd 1.16
        
        Acme thttpd 1.90 a
        
        Acme thttpd 1.95
        
        Acme thttpd 2.0
        
        Acme thttpd 2.0.1
        
        Acme thttpd 2.0.2
        
        Acme thttpd 2.0.3
        
        Acme thttpd 2.0.4
        
        Acme thttpd 2.0.5
        
        Acme thttpd 2.0.6
        
        Acme thttpd 2.0.7
        
        Acme thttpd 2.0.8
        
        Acme thttpd 2.0.9
        
        Acme thttpd 2.10
        
        Acme thttpd 2.11
        
        Acme thttpd 2.12
        
        Acme thttpd 2.13
        
        Acme thttpd 2.14
        
        Acme thttpd 2.15
        
        Acme thttpd 2.16
        
        Acme thttpd 2.17
        
        Acme thttpd 2.18
        

  •         Acme thttpd-2.24.tar.gz
            

- 漏洞信息

7359
thttpd Host: Header Traversal Arbitrary File Access
Remote / Network Access Input Manipulation
Loss of Confidentiality Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2002-10-31 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.23 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Acme thttpd/mini_httpd Virtual Hosting File Disclosure Vulnerability
Access Validation Error 8924
Yes No
2002-10-31 12:00:00 2009-07-11 11:56:00
Discovery is credited to Marcus Breiing.

- 受影响的程序版本

Acme thttpd 2.23 b1
+ S.u.S.E. Linux 8.1
+ S.u.S.E. Linux Personal 9.0
+ S.u.S.E. Linux Personal 8.2
Acme thttpd 2.22
Acme thttpd 2.21 b
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
Acme thttpd 2.21
Acme thttpd 2.20 c
+ Conectiva Linux 9.0
+ S.u.S.E. Linux 8.0
Acme thttpd 2.20 b
+ S.u.S.E. Linux 7.3
Acme thttpd 2.20
Acme thttpd 2.19
Acme thttpd 2.18
Acme thttpd 2.17
Acme thttpd 2.16
Acme thttpd 2.15
- S.u.S.E. Linux 6.4
Acme thttpd 2.14
Acme thttpd 2.13
Acme thttpd 2.12
Acme thttpd 2.11
Acme thttpd 2.10
Acme thttpd 2.0.9
Acme thttpd 2.0.8
Acme thttpd 2.0.7
Acme thttpd 2.0.6
Acme thttpd 2.0.5
+ FREESCO FREESCO 0.3.2
+ FREESCO FREESCO 0.3.1
+ FREESCO FREESCO 0.3 .0
+ FREESCO FREESCO 0.2.7
Acme thttpd 2.0.4
- S.u.S.E. Linux 6.3
- S.u.S.E. Linux 6.2
Acme thttpd 2.0.3
Acme thttpd 2.0.2
Acme thttpd 2.0.1
Acme thttpd 2.0
Acme thttpd 1.95
Acme thttpd 1.90 a
Acme thttpd 1.0
Acme mini_httpd 1.16
Acme mini_httpd 1.15 c
Acme mini_httpd 1.15 b
Acme mini_httpd 1.15
Acme mini_httpd 1.14
Acme mini_httpd 1.13
Acme mini_httpd 1.12
Acme mini_httpd 1.11
Acme mini_httpd 1.10 0
Acme mini_httpd 1.0 1
Acme mini_httpd 1.0 0
Acme thttpd 2.24
Acme mini_httpd 1.18

- 不受影响的程序版本

Acme thttpd 2.24
Acme mini_httpd 1.18

- 漏洞讨论

A file disclosure vulnerability has been reported in Acme thttpd and mini_httpd that is exposed when virtual hosting is enabled. By submitting a directory traversal sequence in the Host: header field of an HTTP request, it is possible to gain unauthorized access to files on the system. If chroot is used, this will disclose the contents of directories under the chroot. This could allow access to other files on the system if chroot is not used.

- 漏洞利用

There is no exploit required.

- 解决方案

SuSE has released an advisory (SuSE-SA:2003:044) to address this issue in SuSE Linux platforms. Affected users are advised to apply fixes as soon as possible. Further information regarding obtaining and applying these fixes can be found in the referenced advisory.

Debian has released an advisory (DSA 396-1) and fixes to address this issue in thttpd.

Conectiva has released a security advisory (CLA-2003:777) which contains fixes to address this issue. Users are advised to upgrade as soon as possible.

This issue has been addressed in thttpd 2.24 and mini_httpd 1.18.


Acme mini_httpd 1.0 0

Acme mini_httpd 1.0 1

Acme thttpd 1.0

Acme mini_httpd 1.10 0

Acme mini_httpd 1.11

Acme mini_httpd 1.12

Acme mini_httpd 1.13

Acme mini_httpd 1.14

Acme mini_httpd 1.15 b

Acme mini_httpd 1.15 c

Acme mini_httpd 1.15

Acme mini_httpd 1.16

Acme thttpd 1.90 a

Acme thttpd 1.95

Acme thttpd 2.0

Acme thttpd 2.0.1

Acme thttpd 2.0.2

Acme thttpd 2.0.3

Acme thttpd 2.0.4

Acme thttpd 2.0.5

Acme thttpd 2.0.6

Acme thttpd 2.0.7

Acme thttpd 2.0.8

Acme thttpd 2.0.9

Acme thttpd 2.10

Acme thttpd 2.11

Acme thttpd 2.12

Acme thttpd 2.13

Acme thttpd 2.14

Acme thttpd 2.15

Acme thttpd 2.16

Acme thttpd 2.17

Acme thttpd 2.18

Acme thttpd 2.19

Acme thttpd 2.20 c

Acme thttpd 2.20 b

Acme thttpd 2.20

Acme thttpd 2.21

Acme thttpd 2.21 b

Acme thttpd 2.22

Acme thttpd 2.23 b1

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站