CVE-2002-1537
CVSS10.0
发布时间 :2003-03-31 00:00:00
修订时间 :2008-09-05 16:30:51
NMCOS    

[原文]admin_ug_auth.php in phpBB 2.0.0 allows local users to gain administrator privileges by directly calling admin_ug_auth.php with modifed form fields such as "u".


[CNNVD]phpBB2管理访问未验证漏洞(CNNVD-200303-114)

        
        phpBB2是一款由PHP编写基于WEB的论坛程序。
        phpBB2的admin_ug_auth.php脚本中处理用户提交的请求处理不正确 ,远程攻击者可以利用这个漏洞提升任意用户权限为论坛管理员权限。
        phpBB2中的admin_ug_auth.php脚本用于设置用户的权限,这表示此脚本只允许管理员权限进行访问操作,不过代码存在错误,攻击者可以发送畸形构建的POST请求给admin_ug_auth.php脚本,可以导致未授权用户获得论坛管理员权限,完全控制论坛功能。
        

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1537
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1537
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200303-114
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/6056
(VENDOR_ADVISORY)  BID  6056
http://www.iss.net/security_center/static/10489.php
(VENDOR_ADVISORY)  XF  phpbb-adminugauth-admin-privileges(10489)
http://archives.neohapsis.com/archives/bugtraq/2002-10/0385.html
(VENDOR_ADVISORY)  BUGTRAQ  20021027 Privilege Escalation Vulnerability In phpBB 2.0.0
http://www.osvdb.org/4284
(UNKNOWN)  OSVDB  4284

- 漏洞信息

phpBB2管理访问未验证漏洞
危急 输入验证
2003-03-31 00:00:00 2005-10-12 00:00:00
远程  
        
        phpBB2是一款由PHP编写基于WEB的论坛程序。
        phpBB2的admin_ug_auth.php脚本中处理用户提交的请求处理不正确 ,远程攻击者可以利用这个漏洞提升任意用户权限为论坛管理员权限。
        phpBB2中的admin_ug_auth.php脚本用于设置用户的权限,这表示此脚本只允许管理员权限进行访问操作,不过代码存在错误,攻击者可以发送畸形构建的POST请求给admin_ug_auth.php脚本,可以导致未授权用户获得论坛管理员权限,完全控制论坛功能。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 使用.htaccesss等访问控制授权限制对/admin目录的访问。
        厂商补丁:
        phpBB Group
        -----------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        phpBB Group Upgrade phpBB 2.0.3
        
        http://www.phpbb.com/downloads.php

- 漏洞信息

4284
phpBB admin_ug_auth.php Form Field Manipulation
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

phpBB contains a flaw that allows a remote attacker to gain administrative privileges. The issue is due to the admin_ug_auth.php script not validating form field input. If an attacker knows the fields required, they can post values that change an arbitrary account into an administrator account.

- 时间线

2002-10-27 Unknow
2002-10-27 Unknow

- 解决方案

Upgrade to version 2.0.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

phpBB2 Unauthorized Administrative Access Vulnerability
Input Validation Error 6056
Yes No
2002-10-28 12:00:00 2009-07-11 06:06:00
Discovery of this vulnerability is credited to Rootsecure.net.

- 受影响的程序版本

phpBB Group phpBB 2.0 .0
phpBB Group phpBB 2.0.3
phpBB Group phpBB 2.0.2
phpBB Group phpBB 2.0.1

- 不受影响的程序版本

phpBB Group phpBB 2.0.3
phpBB Group phpBB 2.0.2
phpBB Group phpBB 2.0.1

- 漏洞讨论

A vulnerability has been discovered in phpBB2 which may allow an unauthorized attacker to gain administrative privileges.

By sending a maliciously constructed post to a vulnerable forum resource, it is possible for an unauthorized user to grant 'administrator' privileges to arbitrary users.

Exploiting this issue could allow a remote attacker to gain complete control of a target forum.

It has been reported that third party utilities that use phpBB v2.0.0 may also be vulnerable to this issue.

- 漏洞利用

A proof of concept is available in the referenced BugTraq message.

- 解决方案

It has been reported that versions later than v2.0.0 are not vulnerable to this issue.

Fixes available:


phpBB Group phpBB 2.0 .0

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站