CVE-2002-1536
CVSS7.5
发布时间 :2003-03-31 00:00:00
修订时间 :2008-09-05 16:30:51
NMCOS    

[原文]Molly IRC bot 0.5 allows remote attackers to execute arbitrary commands via shell metacharacters in (1) the $host variable for nslookup.pl, (2) the $to, $from, or $message variables in pop.pl, (3) the $words or $text variables in sms.pl, or (4) the $server or $printer variables in hpled.pl.


[CNNVD]Hans Persson Molly多个远程命令执行漏洞(CNNVD-200303-099)

        
        Molly是小型简单的IRC BOT程序,可以用于股票信息查询,投票等操作。
        Molly中多个脚本对用户提交的参数缺少正确检查,远程攻击者可以利用这个漏洞以WEB进程权限在系统上执行任意命令。
        plugins/nslookup.pl脚本中在调用SHELL时对用户参数的输入缺少正确过滤,如果用户提交的'$host'变量包SHELL元字符加命令(如scan-associates.net;/bin/ls),可导致命令以WEB权限执行。
        另外unusedplugins/pop.pl和unusedplugins/sms.pl脚本也存在同样的错误,可以用来执行任意命令。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1536
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1536
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200303-099
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/6007
(VENDOR_ADVISORY)  BID  6007
http://online.securityfocus.com/archive/1/296163
(VENDOR_ADVISORY)  BUGTRAQ  20021018 SCAN Associates Advisory: Molly 0.5 - Remote Command Execution
http://www.iss.net/security_center/static/10397.php
(UNKNOWN)  XF  molly-host-execute-commands(10397)
http://archives.neohapsis.com/archives/vulnwatch/2002-q4/0028.html
(UNKNOWN)  VULNWATCH  20021018 SCAN Associates Advisory: Molly 0.5 - Remote Command Execution

- 漏洞信息

Hans Persson Molly多个远程命令执行漏洞
高危 未知
2003-03-31 00:00:00 2005-10-20 00:00:00
远程  
        
        Molly是小型简单的IRC BOT程序,可以用于股票信息查询,投票等操作。
        Molly中多个脚本对用户提交的参数缺少正确检查,远程攻击者可以利用这个漏洞以WEB进程权限在系统上执行任意命令。
        plugins/nslookup.pl脚本中在调用SHELL时对用户参数的输入缺少正确过滤,如果用户提交的'$host'变量包SHELL元字符加命令(如scan-associates.net;/bin/ls),可导致命令以WEB权限执行。
        另外unusedplugins/pop.pl和unusedplugins/sms.pl脚本也存在同样的错误,可以用来执行任意命令。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 脚本中@answer = `/usr/bin/nslookup $host`;行使用如下代码代替:
        $host =~ s/[^\w\.]//g; open(NSLOOKUP, "-|", "/usr/bin/nslookup '$host'"); @answer = ;
        厂商补丁:
        Hans Persson
        ------------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.lysator.liu.se/~unicorn/hacks/molly/

- 漏洞信息

11816
Molly IRC Bot hpled.pl Multiple Variable Arbitrary Command Execution

- 漏洞描述

Unknown or Incomplete

- 时间线

2002-10-18 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Hans Persson Molly Multiple Remote Command Execution Vulnerabilities
Unknown 6007
Yes No
2002-10-18 12:00:00 2009-07-11 06:06:00
Discovery credited to "guejez" <guejez@scan-associates.net>.

- 受影响的程序版本

Hans Persson Molly 0.5

- 漏洞讨论

It has been reported that a remote command execution vulnerability exists in Molly. By constructing a malicious request, it may be possible for a remote attacker to execute arbitrary commands, with the privileges of Molly.

The vulnerability exists in several files in the 'unusedplugins' folder as well as 'plugins/nslookup.pl'.

This issue was reported for Molly 0.5.

- 漏洞利用

There is no exploit code required.

- 解决方案

The author is aware of these vulnerabilities and states that future versions of Molly will not be affected by some of the issues.

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站