CVE-2002-1511
CVSS5.0
发布时间 :2003-03-03 00:00:00
修订时间 :2008-09-10 15:14:48
NMCOS    

[原文]The vncserver wrapper for vnc before 3.3.3r2-21 uses the rand() function instead of srand(), which causes vncserver to generate weak cookies.


[CNNVD]TightVNC Server验证Cookie可预测漏洞(CNNVD-200303-013)

        
        TightVNC是一款由Constantin Kaplinsky分发和维护的VNC(Virtual Network Computing)软件,用于远程图形化的连接访问,可使用在Microsoft Windows及各种Unix类操作系统下。
        TightVNC使用不强壮的方式来生成随机X服务器验证Cookie,远程攻击者可以利用这个漏洞猜测验证Cookie,未授权访问X服务器。
        VNC服务器作为X服务器的时候,启动此VNC的脚本生成MIT X Cookie(用于X验证)没有使用强壮的随机号码生成器,这可导致攻击者可以轻易猜测验证Cookie。
        VNC DES验证即使使用'challenge-response'方式实现,对每个验证的尝试产生随机和不同的'挑战',但是由于某个函数中的一个设计错误,生成的随机'挑战'采用每次验证尝试的当前时间作为随机种子,因此两个在同一秒的验证尝试可导致接收相同的'挑战',通过网络嗅探和猜测可以未授权用户访问VNC服务器。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:att:vnc:3.3.3r2
cpe:/a:tightvnc:tightvnc:1.2.2
cpe:/a:att:vnc:3.3.6
cpe:/a:att:vnc:3.3.4
cpe:/a:tightvnc:tightvnc:1.2.1
cpe:/a:tightvnc:tightvnc:1.2.5
cpe:/a:tightvnc:tightvnc:1.2.4
cpe:/a:tightvnc:tightvnc:1.2.3
cpe:/a:tightvnc:tightvnc:1.2.0
cpe:/a:att:vnc:3.3.5
cpe:/a:att:vnc:3.3.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1511
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1511
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200303-013
(官方数据源) CNNVD

- 其它链接及资源

http://www.redhat.com/support/errata/RHSA-2003-041.html
(VENDOR_ADVISORY)  REDHAT  RHSA-2003:041
http://www.iss.net/security_center/static/11384.php
(VENDOR_ADVISORY)  XF  vnc-rand-weak-cookie(11384)
http://changelogs.credativ.org/debian/pool/main/v/vnc/vnc_3.3.6-3/changelog
(UNKNOWN)  CONFIRM  http://changelogs.credativ.org/debian/pool/main/v/vnc/vnc_3.3.6-3/changelog
http://www.securityfocus.com/bid/6905
(UNKNOWN)  BID  6905
http://www.redhat.com/support/errata/RHSA-2003-068.html
(UNKNOWN)  REDHAT  RHSA-2003:068
http://www.mandrakesoft.com/security/advisories?name=MDKSA-2003:022
(UNKNOWN)  MANDRAKE  MDKSA-2003:022
http://sunsolve.sun.com/pub-cgi/retrieve.pl?doc=fsalert/56161
(UNKNOWN)  SUNALERT  56161
http://security.gentoo.org/glsa/glsa-200302-15.xml
(UNKNOWN)  GENTOO  200302-15
http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000640
(UNKNOWN)  CONECTIVA  CLSA-2003:640

- 漏洞信息

TightVNC Server验证Cookie可预测漏洞
中危 设计错误
2003-03-03 00:00:00 2005-05-13 00:00:00
远程  
        
        TightVNC是一款由Constantin Kaplinsky分发和维护的VNC(Virtual Network Computing)软件,用于远程图形化的连接访问,可使用在Microsoft Windows及各种Unix类操作系统下。
        TightVNC使用不强壮的方式来生成随机X服务器验证Cookie,远程攻击者可以利用这个漏洞猜测验证Cookie,未授权访问X服务器。
        VNC服务器作为X服务器的时候,启动此VNC的脚本生成MIT X Cookie(用于X验证)没有使用强壮的随机号码生成器,这可导致攻击者可以轻易猜测验证Cookie。
        VNC DES验证即使使用'challenge-response'方式实现,对每个验证的尝试产生随机和不同的'挑战',但是由于某个函数中的一个设计错误,生成的随机'挑战'采用每次验证尝试的当前时间作为随机种子,因此两个在同一秒的验证尝试可导致接收相同的'挑战',通过网络嗅探和猜测可以未授权用户访问VNC服务器。
        

- 公告与补丁

        厂商补丁:
        MandrakeSoft
        ------------
        MandrakeSoft已经为此发布了一个安全公告(MDKSA-2003:022)以及相应补丁:
        MDKSA-2003:022:Updated vnc packages fix cookie vulnerability
        链接:
        http://www.linux-mandrake.com/en/security/2003/2003-022.php

        补丁下载:
        Updated Packages:
        Linux-Mandrake 7.2:
        ftp://download.sourceforge.net/pub/mirrors/mandrake/updates/7.2/RPMS/vnc-3.3.3-8.4mdk.i586.rpm
        ftp://download.sourceforge.net/pub/mirrors/mandrake/updates/7.2/RPMS/vnc-SVGALIB-3.3.3-8.4mdk.i586.rpm
        ftp://download.sourceforge.net/pub/mirrors/mandrake/updates/7.2/RPMS/vnc-doc-3.3.3-8.4mdk.i586.rpm
        ftp://download.sourceforge.net/pub/mirrors/mandrake/updates/7.2/RPMS/vnc-java-3.3.3-8.4mdk.i586.rpm
        ftp://download.sourceforge.net/pub/mirrors/mandrake/updates/7.2/RPMS/vnc-server-3.3.3-8.4mdk.i586.rpm
        ftp://download.sourceforge.net/pub/mirrors/mandrake/updates/7.2/SRPMS/vnc-3.3.3-8.4mdk.src.rpm
        Mandrake Linux 8.0:
        ftp://download.sourceforge.net/pub/mirrors/mandrake/updates/8.0/RPMS/vnc-3.3.3r2-9.3mdk.i586.rpm
        ftp://download.sourceforge.net/pub/mirrors/mandrake/updates/8.0/RPMS/vnc-doc-3.3.3r2-9.3mdk.i586.rpm
        ftp://download.sourceforge.net/pub/mirrors/mandrake/updates/8.0/RPMS/vnc-server-3.3.3r2-9.3mdk.i586.rpm
        ftp://download.sourceforge.net/pub/mirrors/mandrake/updates/8.0/SRPMS/vnc-3.3.3r2-9.3mdk.src.rpm
        Mandrake Linux 8.0/PPC:
        ftp://download.sourceforge.net/pub/mirrors/mandrake/updates/ppc/8.0/RPMS/vnc-3.3.3r2-9.3mdk.ppc.rpm
        ftp://download.sourceforge.net/pub/mirrors/mandrake/updates/ppc/8.0/RPMS/vnc-doc-3.3.3r2-9.3mdk.ppc.rpm
        ftp://download.sourceforge.net/pub/mirrors/mandrake/updates/ppc/8.0/RPMS/vnc-server-3.3.3r2-9.3mdk.ppc.rpm
        ftp://download.sourceforge.net/pub/mirrors/mandrake/updates/ppc/8.0/SRPMS/vnc-3.3.3r2-9.3mdk.src.rpm
        Mandrake Linux 8.1:
        ftp://download.sourceforge.net/pub/mirrors/mandrake/updates/8.1/RPMS/vnc-3.3.3r2-9.3mdk.i586.rpm
        ftp://download.sourceforge.net/pub/mirrors/mandrake/updates/8.1/RPMS/vnc-doc-3.3.3r2-9.3mdk.i586.rpm
        ftp://download.sourceforge.net/pub/mirrors/mandrake/updates/8.1/RPMS/vnc-server-3.3.3r2-9.3mdk.i586.rpm
        ftp://download.sourceforge.net/pub/mirrors/mandrake/updates/8.1/SRPMS/vnc-3.3.3r2-9.3mdk.src.rpm
        Mandrake Linux 8.2:
        ftp://download.sourceforge.net/pub/mirrors/mandrake/updates/8.2/RPMS/vnc-3.3.3r2-9.3mdk.i586.rpm
        ftp://download.sourceforge.net/pub/mirrors/mandrake/updates/8.2/RPMS/vnc-doc-3.3.3r2-9.3mdk.i586.rpm
        ftp://download.sourceforge.net/pub/mirrors/mandrake/updates/8.2/RPMS/vnc-server-3.3.3r2-9.3mdk.i586.rpm
        ftp://download.sourceforge.net/pub/mirrors/mandrake/updates/8.2/SRPMS/vnc-3.3.3r2-9.3mdk.src.rpm
        Mandrake Linux 8.2/PPC:
        ftp://download.sourceforge.net/pub/mirrors/mandrake/updates/ppc/8.2/RPMS/vnc-3.3.3r2-9.3mdk.ppc.rpm
        ftp://download.sourceforge.net/pub/mirrors/mandrake/updates/ppc/8.2/RPMS/vnc-doc-3.3.3r2-9.3mdk.ppc.rpm
        ftp://download.sourceforge.net/pub/mirrors/mandrake/updates/ppc/8.2/RPMS/vnc-server-3.3.3r2-9.3mdk.ppc.rpm
        ftp://download.sourceforge.net/pub/mirrors/mandrake/updates/ppc/8.2/SRPMS/vnc-3.3.3r2-9.3mdk.src.rpm
        Mandrake Linux 9.0:
        ftp://download.sourceforge.net/pub/mirrors/mandrake/updates/9.0/RPMS/tightvnc-1.2.5-2.3mdk.i586.rpm
        ftp://download.sourceforge.net/pub/mirrors/mandrake/updates/9.0/RPMS/tightvnc-doc-1.2.5-2.3mdk.i586.rpm
        ftp://download.sourceforge.net/pub/mirrors/mandrake/updates/9.0/RPMS/tightvnc-server-1.2.5-2.3mdk.i586.rpm
        ftp://download.sourceforge.net/pub/mirrors/mandrake/updates/9.0/SRPMS/tightvnc-1.2.5-2.3mdk.src.rpm
        上述升级软件还可以在下列地址中的任意一个镜像ftp服务器上下载:
        
        http://www.mandrakesecure.net/en/ftp.php

        RedHat
        ------
        RedHat已经为此发布了一个安全公告(RHSA-2003:041-12)以及相应补丁:
        RHSA-2003:041-12:Updated VNC packages fix replay and cookie vulnerabilities
        链接:https://www.redhat.com/support/errata/RHSA-2003-041.html
        补丁下载:
        Red Hat Linux 7.0:
        SRPMS:
        ftp://updates.redhat.com/7.0/en/os/SRPMS/vnc-3.3.3r2-18.6.src.rpm
        i386:
        

- 漏洞信息

6278
VNC Weak Authentication Cookie

- 漏洞描述

Unknown or Incomplete

- 时间线

2002-10-11 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

TightVNC Server Authentication Cookie Predictability Vulnerability
Design Error 6905
Yes No
2002-11-15 12:00:00 2009-07-11 08:06:00
This vulnerability was discovered and fixed by the vendor.

- 受影响的程序版本

TightVNC TightVNC 1.2.5
+ Mandriva Linux Mandrake 9.0
TightVNC TightVNC 1.2.4
TightVNC TightVNC 1.2.3
TightVNC TightVNC 1.2.2
TightVNC TightVNC 1.2.1
TightVNC TightVNC 1.2 .0
AT&T VNC 3.3.6
+ Gentoo Linux 1.4 _rc2
+ Gentoo Linux 1.4 _rc1
AT&T VNC 3.3.5
AT&T VNC 3.3.4
AT&T VNC 3.3.3 R2
+ Conectiva Linux Enterprise Edition 1.0
+ Mandriva Linux Mandrake 8.2 ppc
+ Mandriva Linux Mandrake 8.2
+ Mandriva Linux Mandrake 8.1 ia64
+ Mandriva Linux Mandrake 8.1
+ Mandriva Linux Mandrake 8.0 ppc
+ Mandriva Linux Mandrake 8.0
- Red Hat Linux 6.2
- RedHat Linux 7.2 ia64
- RedHat Linux 7.2 i686
- RedHat Linux 7.2 i586
- RedHat Linux 7.2 i386
- RedHat Linux 7.2 alpha
- RedHat Linux 7.2
- RedHat Linux 7.1 ia64
- RedHat Linux 7.1 i686
- RedHat Linux 7.1 i586
- RedHat Linux 7.1 i386
- RedHat Linux 7.1 alpha
- RedHat Linux 7.1
- RedHat Linux 7.0 sparc
- RedHat Linux 7.0 i686
- RedHat Linux 7.0 i386
- RedHat Linux 7.0 alpha
- RedHat Linux 7.0
- RedHat Linux 6.2 sparc
- RedHat Linux 6.2 i386
- RedHat Linux 6.2 alpha
+ Sun Linux 5.0.7
+ Sun Linux 5.0
+ Sun LX50
AT&T VNC 3.3.3
- Apple Mac OS 9 9.0
- BSDI BSD/OS 4.0
+ Conectiva Linux 8.0
+ Conectiva Linux 7.0
- Conectiva Linux 6.0
- Conectiva Linux graficas
- Conectiva Linux ecommerce
- Debian Linux 2.2
- FreeBSD FreeBSD 4.2
- HP HP-UX 11.11
+ Mandriva Linux Mandrake 7.2
- Microsoft Windows 2000 Professional
- Microsoft Windows 98SE
- Microsoft Windows NT 4.0
- OpenBSD OpenBSD 2.8
+ OpenBSD OpenBSD 2.0
- RedHat Linux 7.0
- S.u.S.E. Linux 7.0
- Sun Solaris 8_sparc
- Sun Solaris 7.0
TightVNC TightVNC 1.2.7
TightVNC TightVNC 1.2.6

- 不受影响的程序版本

TightVNC TightVNC 1.2.7
TightVNC TightVNC 1.2.6

- 漏洞讨论

The script responsible for starting the TightVNC server uses weak entropy to generate random X Server authentication cookies.

When executed the vulnerable script creates an MIT 'X cookie' that is used when the VNC server authenticates with the X Server. Due to insufficient entropy when creating this token, it may be possible for an attacker to predict the necessary response and use it to successfully authenticate with the X server on the vulnerable system.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Sun have made fixes available to address this issue in Sun Linux 5.0.7. Fixes are linked below.

Red Hat has released an advisory (RHSA-2003:041-12) and fixes as a solution for this vulnerability.

Gentoo Linux has released an advisory. Users who have installed net-misc/vnc or net-misc/tightvnc are advised to upgrade by issuing the following commands:

emerge sync
emerge -u tightvnc
emerge clean

or

emerge sync
emerge -u vnc
emerge clean

Conectiva has released advisory CLA-2003:640 with fixes to address this issue. Security advisory CLSA-2003:670 has also been released containing a fix for CLEE 1.0, users are advised to upgrade as soon as possible.

Fixes:


TightVNC TightVNC 1.2.2

TightVNC TightVNC 1.2.5

AT&T VNC 3.3.3

AT&T VNC 3.3.3 R2

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站