CVE-2002-1498
CVSS5.0
发布时间 :2003-04-02 00:00:00
修订时间 :2008-09-05 16:30:45
NMCOS    

[原文]Directory traversal vulnerability in SWServer 2.2 and earlier allows remote attackers to read arbitrary files via a URL containing .. sequences with "/" or "\" characters.


[CNNVD]SWServer目录遍历漏洞(CNNVD-200304-060)

        SWServer 2.2及其之前版本存在目录遍历漏洞。远程攻击者借助包含带有"/"或者"\"字符的..序列的URL读取任意文件。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1498
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1498
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200304-060
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/5590
(VENDOR_ADVISORY)  BID  5590
http://www.iss.net/security_center/static/9981.php
(VENDOR_ADVISORY)  XF  swserver-encoded-directory-traversal(9981)
http://archives.neohapsis.com/archives/bugtraq/2002-08/0307.html
(VENDOR_ADVISORY)  BUGTRAQ  20020828 SWServer 2.2 directory traversal bug

- 漏洞信息

SWServer目录遍历漏洞
中危 路径遍历
2003-04-02 00:00:00 2005-10-20 00:00:00
远程  
        SWServer 2.2及其之前版本存在目录遍历漏洞。远程攻击者借助包含带有"/"或者"\"字符的..序列的URL读取任意文件。

- 公告与补丁

        This vulnerability is fixed in version 2.3:
        Trevor Lee SWServer 2.2
        

- 漏洞信息

8445
SWServer Traversal Arbitrary File Read
Input Manipulation

- 漏洞描述

Unknown or Incomplete

- 时间线

2002-08-28 Unknow
2002-08-28 Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

SWServer Directory Traversal Vulnerability
Input Validation Error 5590
Yes No
2002-08-28 12:00:00 2009-07-11 03:56:00
Discovered by Bugtest <aluigi@pivx.com>.

- 受影响的程序版本

Trevor Lee SWServer 2.2
Trevor Lee SWServer 2.3

- 不受影响的程序版本

Trevor Lee SWServer 2.3

- 漏洞讨论

SWServer is a simple webserver writtin in Java. SWSserver fails to restrict clients from requesting files from outside of the webroot tree. Malicious remote attackers may exploit this vulnerability to obtain potentially sensitive files.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com &lt;mailto:vuldb@securityfocus.com&gt;.

- 解决方案

This vulnerability is fixed in version 2.3:


Trevor Lee SWServer 2.2

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站