CVE-2002-1480
CVSS6.8
发布时间 :2003-04-22 00:00:00
修订时间 :2008-09-05 16:30:42
NMCOES    

[原文]Cross-site scripting (XSS) vulnerability in phpGB before 1.20 allows remote attackers to inject arbitrary HTML or script into guestbook pages, which is executed when the administrator deletes the entry.


[CNNVD]phpGB HTML注入漏洞(CNNVD-200304-130)

        phpGB 1.20之前版本存在跨站脚本(XSS)漏洞。远程攻击者可以利用该漏洞向留言簿页面注入任意HTML或脚本,该漏洞在管理员删除登录时执行。

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1480
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1480
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200304-130
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/5676
(VENDOR_ADVISORY)  BID  5676
http://www.iss.net/security_center/static/10060.php
(VENDOR_ADVISORY)  XF  phpgb-entry-deletion-xss(10060)
http://archives.neohapsis.com/archives/bugtraq/2002-09/0069.html
(VENDOR_ADVISORY)  BUGTRAQ  20020909 phpGB: cross site scripting bug

- 漏洞信息

phpGB HTML注入漏洞
中危 跨站脚本
2003-04-22 00:00:00 2005-10-20 00:00:00
远程  
        phpGB 1.20之前版本存在跨站脚本(XSS)漏洞。远程攻击者可以利用该漏洞向留言簿页面注入任意HTML或脚本,该漏洞在管理员删除登录时执行。

- 公告与补丁

        This issue has been addressed in phpGB 1.2.0 and greater.

- 漏洞信息 (21780)

phpGB 1.1 HTML Injection Vulnerability (EDBID:21780)
php webapps
2002-09-09 Verified
0 ppp-design
N/A [点击下载]
source: http://www.securityfocus.com/bid/5676/info

phpGB is subject to HTML injection attacks.

phpGB fails to check for the presence of HTML tags when generating guestbook entries. It is reported that an attacker may inject HTML and script code into guestbook entries, which will be executed in the web client of the administrative guestbook user when the admin attempts to delete the entry. 

Enter the following guestbookentry:

"delete me <script>alert(document.cookie)</script>"

		

- 漏洞信息

9215
phpGB Guestbook Page Post XSS
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2002-09-09 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

phpGB HTML Injection Vulnerability
Input Validation Error 5676
Yes No
2002-09-09 12:00:00 2009-07-11 05:06:00
Discovery credited to ppp-design

- 受影响的程序版本

phpGB phpGB 1.1
phpGB phpGB 1.2

- 不受影响的程序版本

phpGB phpGB 1.2

- 漏洞讨论

phpGB is subject to HTML injection attacks.

phpGB fails to check for the presence of HTML tags when generating guestbook entries. It is reported that an attacker may inject HTML and script code into guestbook entries, which will be executed in the web client of the administrative guestbook user when the admin attempts to delete the entry.

- 漏洞利用

The following proof of concept code was supplied by ppp-design:

Enter the following guestbookentry:

"delete me &lt;script&gt;alert(document.cookie)&lt;/script&gt;"

- 解决方案

This issue has been addressed in phpGB 1.2.0 and greater.

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站