CVE-2002-1477
CVSS7.5
发布时间 :2003-04-22 00:00:00
修订时间 :2008-09-05 16:30:42
NMCOS    

[原文]graphs.php in Cacti before 0.6.8 allows remote authenticated Cacti administrators to execute arbitrary commands via shell metacharacters in the title during edit mode.


[CNNVD]Raxnet Cacti命令行执行漏洞(CNNVD-200304-132)

        Cacti 0.6.8之前版本的graphs.php存在漏洞。远程Cacti认证管理者可以借助编辑模式标题中的shell元字符执行任意命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:the_cacti_group:cacti:0.6.3
cpe:/a:the_cacti_group:cacti:0.6.5
cpe:/a:the_cacti_group:cacti:0.6.4
cpe:/a:the_cacti_group:cacti:0.5
cpe:/a:the_cacti_group:cacti:0.6.8
cpe:/a:the_cacti_group:cacti:0.6.6
cpe:/a:the_cacti_group:cacti:0.6.1
cpe:/a:the_cacti_group:cacti:0.6
cpe:/a:the_cacti_group:cacti:0.6.2
cpe:/a:the_cacti_group:cacti:0.6.7

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1477
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1477
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200304-132
(官方数据源) CNNVD

- 其它链接及资源

http://www.iss.net/security_center/static/10048.php
(VENDOR_ADVISORY)  XF  cacti-graph-label-commands(10048)
http://www.debian.org/security/2002/dsa-164
(VENDOR_ADVISORY)  DEBIAN  DSA-164
http://archives.neohapsis.com/archives/bugtraq/2002-09/0028.html
(VENDOR_ADVISORY)  BUGTRAQ  20020903 Cacti security issues
http://www.knights-of-the-routing-table.org/advisories/krt_001_20020903_cacti.txt
(UNKNOWN)  MISC  http://www.knights-of-the-routing-table.org/advisories/krt_001_20020903_cacti.txt
http://www.securityfocus.com/bid/5627
(UNKNOWN)  BID  5627

- 漏洞信息

Raxnet Cacti命令行执行漏洞
高危 输入验证
2003-04-22 00:00:00 2006-08-28 00:00:00
远程  
        Cacti 0.6.8之前版本的graphs.php存在漏洞。远程Cacti认证管理者可以借助编辑模式标题中的shell元字符执行任意命令。

- 公告与补丁

        Fixes are available:
        Raxnet Cacti 0.5
        
        Raxnet Cacti 0.6
        
        Raxnet Cacti 0.6.1
        
        Raxnet Cacti 0.6.2
        
        Raxnet Cacti 0.6.3
        
        Raxnet Cacti 0.6.4
        
        Raxnet Cacti 0.6.5
        
        Raxnet Cacti 0.6.6
        
        Raxnet Cacti 0.6.7
        
        Raxnet Cacti 0.6.8
        

- 漏洞信息

8995
Cacti graphs.php Edit Mode Arbitrary Command Execution
Remote / Network Access

- 漏洞描述

Unknown or Incomplete

- 时间线

2002-09-03 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Raxnet Cacti Command Execution Vulnerability
Input Validation Error 5627
Yes No
2002-09-04 12:00:00 2009-07-11 03:56:00
Reported by Knights of the Routing Table <knights@knights-of-the-routing-table.org>.

- 受影响的程序版本

Raxnet Cacti 0.6.8
Raxnet Cacti 0.6.7
+ Debian Linux 3.0
Raxnet Cacti 0.6.6
Raxnet Cacti 0.6.5
Raxnet Cacti 0.6.4
Raxnet Cacti 0.6.3
Raxnet Cacti 0.6.2
Raxnet Cacti 0.6.1
Raxnet Cacti 0.6
Raxnet Cacti 0.5
Raxnet Cacti 0.6.8 a

- 不受影响的程序版本

Raxnet Cacti 0.6.8 a

- 漏洞讨论

Raxnet Cacti is a frontend for rrdtool, a round robin database for monitoring network activity. It stores information to create graphs and populate them with information from a MySQL database.

Cacti does not properly validate input into fields that should only contain text. If a command is entered into a label field on a graph, Cacti will execute the command on the underlying system.

It has been reported that the attacker must have administrative access to Cacti to exploit this issue.

- 漏洞利用

This vulnerability can be exploited with a web browser.

- 解决方案

Fixes are available:


Raxnet Cacti 0.5

Raxnet Cacti 0.6

Raxnet Cacti 0.6.1

Raxnet Cacti 0.6.2

Raxnet Cacti 0.6.3

Raxnet Cacti 0.6.4

Raxnet Cacti 0.6.5

Raxnet Cacti 0.6.6

Raxnet Cacti 0.6.7

Raxnet Cacti 0.6.8

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站