发布时间 :2003-06-09 00:00:00
修订时间 :2008-09-05 16:30:39

[原文]details2.php in OrganicPHP PHP-affiliate 1.0, and possibly later versions, allows remote attackers to modify information of other users by modifying certain hidden form fields.

[CNNVD]PHP affiliate远程更改用户信息漏洞(CNNVD-200306-017)

        PHP Affiliate是一款站点URL信息加入程序,可以用于显示连接、标题等推广站点。
        PHP Affiliate中的details.php对用户提交的输入缺少正确检查,远程攻击者可以利用这个漏洞修改其他用户的站点连接信息。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(VENDOR_ADVISORY)  XF  phpaffiliate-details-account-access(9858)
(VENDOR_ADVISORY)  BUGTRAQ  20020815 Input validation attack in php-affiliate-v1.0

- 漏洞信息

PHP affiliate远程更改用户信息漏洞
中危 设计错误
2003-06-09 00:00:00 2005-10-20 00:00:00
        PHP Affiliate是一款站点URL信息加入程序,可以用于显示连接、标题等推广站点。
        PHP Affiliate中的details.php对用户提交的输入缺少正确检查,远程攻击者可以利用这个漏洞修改其他用户的站点连接信息。

- 公告与补丁

        * 在用户访问details2.php时检查用户合法的session:
         if (session_is_registered("valid_user"))
        WHERE refid = '$HTTP_SESSION_VARS[valid_user]'

- 漏洞信息

OrganicPHP PHP-Affiliate details.php Unauthorized Account Modification
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

PHP-Affiliate contains a flaw related to the details.php script that may allow an attacker to gain elevated privileges. The issue is due to the script passing input to the details2.php script without verifying authentication credentials. By modifying the user ID field and supplying it to details2.php, an attacker may be able to modify arbitrary accounts to elevate their privileges.

- 时间线

2002-08-15 Unknow
2002-08-15 Unknow

- 解决方案

Upgrade to version 1.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

OrganicPHP PHP-Affiliate Details.PHP Hidden Field Authentication Bypassing Vulnerability
Design Error 5482
Yes No
2002-08-15 12:00:00 2009-07-11 03:56:00
Vulnerability discovery credited to MOD <>.

- 受影响的程序版本

OrganicPHP PHP-Affiliate 1.1
OrganicPHP PHP-Affiliate 1.0
OrganicPHP PHP-Affiliate 1.2

- 不受影响的程序版本

OrganicPHP PHP-Affiliate 1.2

- 漏洞讨论

PHP-Affiliate is a freely available, open source web site affiliate software package. It is written in PHP, and designed for use on Unix, Linux, and Microsoft Windows operating systems.

PHP-Affiliate uses a hidden field when the details.php page is used to edit referral information. An attacker could exploit this to gain arbitrary access to the details of other users.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: &lt;;.

- 解决方案

The vendor has released patches addressing this issue:

OrganicPHP PHP-Affiliate 1.0

- 相关参考