CVE-2002-1430
CVSS5.0
发布时间 :2003-04-11 00:00:00
修订时间 :2008-09-05 16:30:34
NMCOS    

[原文]Unknown vulnerability in Sympoll 1.2 allows remote attackers to read arbitrary files when register_globals is enabled, possibly by modifying certain PHP variables through URL parameters.


[CNNVD]Sympoll远程文件泄露漏洞(CNNVD-200304-105)

        
        Sympoll是一款可定制的PHP编写的投票系统。
        Sympoll对变量的完整性缺少正确的检查,远程攻击者可以利用这个漏洞以WEB服务进程的权限查看系统上任意文件内容。
        Sympoll对用户提交的参数缺少充分的检查,在php.ini配置文件中'register_globals'选项为'on'的情况下,可导致远程攻击者以WEB进程的权限查看系统任意文件内容,造成敏感信息泄露。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1430
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1430
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200304-105
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/5360
(VENDOR_ADVISORY)  BID  5360
http://www.iss.net/security_center/static/9723.php
(VENDOR_ADVISORY)  XF  sympoll-php-view-files(9723)
http://www.ralusp.net/downloads/sympoll/changelog.txt
(UNKNOWN)  CONFIRM  http://www.ralusp.net/downloads/sympoll/changelog.txt
http://archives.neohapsis.com/archives/bugtraq/2002-07/0401.html
(VENDOR_ADVISORY)  BUGTRAQ  20020730 [ADVISORY]: Arbitrary file disclosure vulnerability in Sympoll 1.2

- 漏洞信息

Sympoll远程文件泄露漏洞
中危 输入验证
2003-04-11 00:00:00 2005-05-13 00:00:00
远程  
        
        Sympoll是一款可定制的PHP编写的投票系统。
        Sympoll对变量的完整性缺少正确的检查,远程攻击者可以利用这个漏洞以WEB服务进程的权限查看系统上任意文件内容。
        Sympoll对用户提交的参数缺少充分的检查,在php.ini配置文件中'register_globals'选项为'on'的情况下,可导致远程攻击者以WEB进程的权限查看系统任意文件内容,造成敏感信息泄露。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 设置php.ini配置文件中的'register_globals'选项为'off'。
        厂商补丁:
        Synthetic Reality
        -----------------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        Synthetic Reality Upgrade Sympoll 1.3
        
        http://www.ralusp.net/downloads/sympoll/sympoll.tar.gz

- 漏洞信息

14537
Sympoll Unspecified PHP Variable Manipulation Arbitrary File Access

- 漏洞描述

Unknown or Incomplete

- 时间线

2002-07-30 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Sympoll File Disclosure Vulnerability
Input Validation Error 5360
Yes No
2002-07-30 12:00:00 2009-07-11 02:56:00
Discovery of this issue is credited to Mats Linander.

- 受影响的程序版本

Synthetic Reality Sympoll 1.2
Synthetic Reality Sympoll 1.3

- 不受影响的程序版本

Synthetic Reality Sympoll 1.3

- 漏洞讨论

Sympoll 1.2 is prone to an issue which may allow remote attackers to disclose the contents of arbitrary webserver readable files. This vulnerability is only present on hosts which are running the vulnerable version of the software and have the PHP 'register_globals' directive enabled. The source of this vulnerability is reported to be insufficient integrity checking of variables.

- 漏洞利用

This issue may be exploited with a web browser.

- 解决方案

This vulnerability is not exploitable if the 'register_globals' PHP directive is disabled.

The vendor has released fixes which address this issue:


Synthetic Reality Sympoll 1.2

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站