CVE-2002-1422
CVSS5.0
发布时间 :2003-04-11 00:00:00
修订时间 :2008-09-05 16:30:33
NMCOES    

[原文]admbrowse.php in FUDforum before 2.2.0 allows remote attackers to create or delete files via URL-encoded pathnames in the cur and dest parameters.


[CNNVD]Ilia Alshanetsky FUDForum文件修改漏洞(CNNVD-200304-108)

        FUDforum 2.2.0之前版本的admbrowse.php存在漏洞。远程攻击者可以借助cur和dest参数的编码URL路径创建或删除文件。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:ilia_alshanetsky:fudforum:1.9.8
cpe:/a:ilia_alshanetsky:fudforum:1.2.8
cpe:/a:ilia_alshanetsky:fudforum:2.0.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1422
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1422
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200304-108
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/5502
(VENDOR_ADVISORY)  BID  5502
http://www.iss.net/security_center/static/9901.php
(VENDOR_ADVISORY)  XF  fudforum-admnbrowse-modify-files(9901)
http://online.securityfocus.com/archive/1/288042
(VENDOR_ADVISORY)  BUGTRAQ  20020818 FUDforum file access and SQL Injection
http://archives.neohapsis.com/archives/vulnwatch/2002-q3/0082.html
(UNKNOWN)  VULNWATCH  20020818 FUDforum file access and SQL Injection

- 漏洞信息

Ilia Alshanetsky FUDForum文件修改漏洞
中危 设计错误
2003-04-11 00:00:00 2005-10-20 00:00:00
远程  
        FUDforum 2.2.0之前版本的admbrowse.php存在漏洞。远程攻击者可以借助cur和dest参数的编码URL路径创建或删除文件。

- 公告与补丁

        The following upgrades are available:
        Ilia Alshanetsky FUDForum 1.2.8
        
        Ilia Alshanetsky FUDForum 1.9.8
        
        Ilia Alshanetsky FUDForum 2.0.2
        

- 漏洞信息 (21724)

Ilia Alshanetsky FUDForum 1.2.8/1.9.8/2.0.2 File Modification Vulnerability (EDBID:21724)
php webapps
2002-08-19 Verified
0 Ulf Harnhammar
N/A [点击下载]
source: http://www.securityfocus.com/bid/5502/info

Reportedly, it is possible for an administrator to manipulate (create, modify etc.) files outside of the FUDForum directories. This vulnerability is present in the 'adm/admbrowse.php' script. The vulnerability is the result of FUDForum allowing access to files and directories outside of FUDForum directories.

http://victim.com/admbrowse.php?down=1&cur=%2Fetc%2F&dest=passwd&rid=1&S=[someid]		

- 漏洞信息

11376
FUDforum admbrowse.php URL-Encoded Pathname Arbitrary File Modification
Remote / Network Access

- 漏洞描述

Unknown or Incomplete

- 时间线

2002-08-18 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Ilia Alshanetsky FUDForum File Modification Vulnerability
Design Error 5502
Yes No
2002-08-19 12:00:00 2009-07-11 03:56:00
Discovery credited to Ulf Harnhammar <ulfh@update.uu.se>.

- 受影响的程序版本

Ilia Alshanetsky FUDForum 2.0.2
Ilia Alshanetsky FUDForum 1.9.8
Ilia Alshanetsky FUDForum 1.2.8
Ilia Alshanetsky FUDForum 2.2.3
Ilia Alshanetsky FUDForum 2.2 .0

- 不受影响的程序版本

Ilia Alshanetsky FUDForum 2.2.3
Ilia Alshanetsky FUDForum 2.2 .0

- 漏洞讨论

Reportedly, it is possible for an administrator to manipulate (create, modify etc.) files outside of the FUDForum directories. This vulnerability is present in the 'adm/admbrowse.php' script. The vulnerability is the result of FUDForum allowing access to files and directories outside of FUDForum directories.

- 漏洞利用

The following proof of concept was provided by Ulf Harnhammar &lt;ulfh@update.uu.se&gt;:

http://victim.com/admbrowse.php?down=1&amp;cur=%2Fetc%2F&amp;dest=passwd&amp;rid=1&amp;S=[someid]

- 解决方案

The following upgrades are available:


Ilia Alshanetsky FUDForum 1.2.8

Ilia Alshanetsky FUDForum 1.9.8

Ilia Alshanetsky FUDForum 2.0.2

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站