CVE-2002-1397
CVSS7.5
发布时间 :2003-01-17 00:00:00
修订时间 :2016-10-17 22:26:49
NMCOS    

[原文]Vulnerability in the cash_words() function for PostgreSQL 7.2 and earlier allows local users to cause a denial of service and possibly execute arbitrary code via a large negative argument, possibly triggering an integer signedness error or buffer overflow.


[CNNVD]PostgreSQL cash_words()函数缓冲区溢出漏洞(CNNVD-200301-015)

        
        PostgreSQL是一款增强对象-关系数据库管理程序,支持SQL标准子集扩展,包括transactions、foreign keys、subqueries、triggers、用户定义类型等函数。
        PostgreSQL的cash_words()函数对用户提交的参数缺少正确检查,攻击者可以利用这个漏洞进行缓冲区溢出攻击。
        PostgreSQL的cash_words()函数对用户提交的参数缺少判断,攻击者可以提交一个很大的负值数据而导致产生缓冲区溢出,攻击者可能可以利用这个漏洞以PostgreSQL进程权限执行任意指令。
        此漏洞可以通过本地利用或者通过利用WEB页SQL注入触发。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:postgresql:postgresql:7.1.3
cpe:/a:postgresql:postgresql:7.2 PostgreSQL 7.2
cpe:/a:postgresql:postgresql:7.0.3
cpe:/a:postgresql:postgresql:7.1 PostgreSQL 7.1
cpe:/a:postgresql:postgresql:7.1.2
cpe:/a:postgresql:postgresql:6.3.2
cpe:/a:postgresql:postgresql:7.1.1
cpe:/a:postgresql:postgresql:6.5.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1397
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1397
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200301-015
(官方数据源) CNNVD

- 其它链接及资源

http://developer.postgresql.org/cvsweb.cgi/pgsql-server/src/backend/utils/adt/cash.c.diff?r1=1.51&r2=1.52
(UNKNOWN)  MISC  http://developer.postgresql.org/cvsweb.cgi/pgsql-server/src/backend/utils/adt/cash.c.diff?r1=1.51&r2=1.52
http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000524
(UNKNOWN)  CONECTIVA  CLA-2002:524
http://marc.info/?l=bugtraq&m=102977465204357&w=2
(UNKNOWN)  BUGTRAQ  20020819 @(#) Mordred Labs advisory 0x0001: Buffer overflow in PostgreSQL
http://www.redhat.com/support/errata/RHSA-2003-001.html
(UNKNOWN)  REDHAT  RHSA-2003:001
http://www.securityfocus.com/bid/5497
(UNKNOWN)  BID  5497
http://xforce.iss.net/xforce/xfdb/9891
(UNKNOWN)  XF  postgresql-cashwords-bo(9891)

- 漏洞信息

PostgreSQL cash_words()函数缓冲区溢出漏洞
高危 边界条件错误
2003-01-17 00:00:00 2005-10-20 00:00:00
本地  
        
        PostgreSQL是一款增强对象-关系数据库管理程序,支持SQL标准子集扩展,包括transactions、foreign keys、subqueries、triggers、用户定义类型等函数。
        PostgreSQL的cash_words()函数对用户提交的参数缺少正确检查,攻击者可以利用这个漏洞进行缓冲区溢出攻击。
        PostgreSQL的cash_words()函数对用户提交的参数缺少判断,攻击者可以提交一个很大的负值数据而导致产生缓冲区溢出,攻击者可能可以利用这个漏洞以PostgreSQL进程权限执行任意指令。
        此漏洞可以通过本地利用或者通过利用WEB页SQL注入触发。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 暂时没有合适的临时解决方法。
        厂商补丁:
        PostgreSQL
        ----------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        
        http://www.ca.postgresql.org/ftpsite/source/v7.2.1/

- 漏洞信息

8998
PostgreSQL cash_words() Function Local Overflow
Local Access Required Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Unknown or Incomplete

- 时间线

2002-08-19 Unknow
2002-08-19 Unknow

- 解决方案

Upgrade to version 7.2.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

PostgreSQL cash_words Function Buffer Overflow Vulnerability
Boundary Condition Error 5497
No Yes
2002-08-19 12:00:00 2009-07-11 03:56:00
Discovery credited to Sir Mordred The Traitor <mordred@s-mail.com>.

- 受影响的程序版本

PostgreSQL PostgreSQL 7.2
+ Mandriva Linux Mandrake 8.2 ppc
+ Mandriva Linux Mandrake 8.2
+ S.u.S.E. Linux 8.0 i386
+ S.u.S.E. Linux 8.0
PostgreSQL PostgreSQL 7.1.3
+ Conectiva Linux 7.0
+ RedHat Linux 7.2
+ S.u.S.E. Linux 7.3 sparc
+ S.u.S.E. Linux 7.3 ppc
+ S.u.S.E. Linux 7.3 i386
+ S.u.S.E. Linux 7.3
+ Trustix Secure Linux 1.5
+ Trustix Secure Linux 1.2
+ Trustix Secure Linux 1.1
PostgreSQL PostgreSQL 7.1.2
+ Mandriva Linux Mandrake 8.1 ia64
+ Mandriva Linux Mandrake 8.1
PostgreSQL PostgreSQL 7.1.1
PostgreSQL PostgreSQL 7.1
PostgreSQL PostgreSQL 7.0.3
+ Conectiva Linux 6.0
+ Mandriva Linux Mandrake 8.0 ppc
+ Mandriva Linux Mandrake 8.0
+ S.u.S.E. Linux 7.1 x86
+ S.u.S.E. Linux 7.1 sparc
+ S.u.S.E. Linux 7.1 ppc
+ S.u.S.E. Linux 7.1 alpha
+ S.u.S.E. Linux 7.1
PostgreSQL PostgreSQL 7.0.2
+ MandrakeSoft Single Network Firewall 7.2
+ Mandriva Linux Mandrake 7.2
+ Wirex Immunix OS 7.0
+ Wirex Immunix OS 7+
PostgreSQL PostgreSQL 6.5.3
+ Wirex Immunix OS 6.2
PostgreSQL PostgreSQL 6.3.2
PostgreSQL PostgreSQL 7.2.2
+ Mandriva Linux Mandrake 9.0
+ Turbolinux Turbolinux Server 8.0
+ Turbolinux Turbolinux Server 7.0
+ Turbolinux Turbolinux Workstation 8.0
PostgreSQL PostgreSQL 7.2.1
+ Conectiva Linux 8.0
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
+ Gentoo Linux 0.7
+ Gentoo Linux 0.5

- 不受影响的程序版本

PostgreSQL PostgreSQL 7.2.2
+ Mandriva Linux Mandrake 9.0
+ Turbolinux Turbolinux Server 8.0
+ Turbolinux Turbolinux Server 7.0
+ Turbolinux Turbolinux Workstation 8.0
PostgreSQL PostgreSQL 7.2.1
+ Conectiva Linux 8.0
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
+ Gentoo Linux 0.7
+ Gentoo Linux 0.5

- 漏洞讨论

A buffer overflow vulnerability has been reported for PostgreSQL. Reportedly, PostgreSQL doesn't properly handle overly long queries when selecting the cash_words() function.

Successful exploitation of this issue may enable an attacker to execute arbitrary code as the database server process.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com &lt;mailto:vuldb@securityfocus.com&gt;.

- 解决方案

Debian has released an advisory with fixes. See the attached advisory (DSA 165-1) for details on obtaining fixes.

Conectiva Linux has fixes available. Further information is available in the referenced advisory.

S.u.S.E. has released an advisory. Fixes for Sparc and Alpha platforms will be forthcoming. Further upgrading instructions are available in the referenced advisory.

Red Hat has released advisories (RHSA-2003:001-16 and RHSA-2003:010-10) which address this and other issues. Please see the attached advisories for details on obtaining and applying fixes.

Mandrake has made fixes available. See referenced advisory MDKSA-2002:062-1 for additional details.

Trustix Secure Linux has released an advisory (TSLSA-2003-0004) which addresses this and other PostgreSQL issues. Users are advised to upgrade as soon as possible.

WireX has released advisory IMNX-2003-7+-005-01 to address this issue.

Fixes available:


PostgreSQL PostgreSQL 6.3.2

PostgreSQL PostgreSQL 6.5.3

PostgreSQL PostgreSQL 7.0.2

PostgreSQL PostgreSQL 7.0.3

PostgreSQL PostgreSQL 7.1

PostgreSQL PostgreSQL 7.1.1

PostgreSQL PostgreSQL 7.1.2

PostgreSQL PostgreSQL 7.1.3

PostgreSQL PostgreSQL 7.2

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站